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1 Introduction

1.1 Preface

The fieldbus configurator SyConPB is mainly based on the universal
fieldbus configurator SyConPB of

Hilscher Gesellschaft für Systemautomation mbH

Rheinstraße 78

D-65795 Hattersheim

Parts of this manual are extracted from the manual of Hilscher and
describe the functionality of SyConPB in combination with the
programming software WinPCL in System 200 of Rexroth Indramat. The
original tool of Hilscher possibly offers more features that cannot be used
in combination with System 200.

The original software was not adapted to the system and/or company
specifications.

Rexroth Indramat assumes the responsibility and the support for
SyConPB and this manual.

1.2 Overview

You configure all devices with one tool. SyConPB checks the
dependencies between the devices. SyConPB only allows configurations
that make sense. In case of doubt SyConPB will give you a warning.

To Hilscher devices you can make downloads of the configuration data.
For other devices, export functions or documentation possibilities are
available.

After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the details of
one device.

Some protocols support standardized files containing information about all
features and limitations of the slave device. SyConPB uses these files for
the configuration.

After the configuration you can switch SyConPB into the diagnostic mode.
You can watch all status information of Hilscher devices, see protocol-
dependent diagnostic information, e.g. live list or slave diagnostic
information on PROFIBUS. In this case a slave not operating correctly will
be displayed in a different color.

SyConPB is a Global Fieldbus
Configurator.

SyConPB Documents Your
Fieldbus System.

SyConPB Uses Standardized
Configuration Files.

SyConPB is a Diagnostic Tool.
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2 Important Directions for Use

2.1 Appropriate Use

Introduction
Rexroth Indramat products represent state-of-the-art developments and
manufacturing. They are tested prior to delivery to ensure operating safety
and reliability.

The products may only be used in the manner that is defined as
appropriate. If they are used in an inappropriate manner, then situations
can develop that may lead to property damage or injury to personnel.

Note: Rexroth Indramat, as manufacturer, is not liable for any
damages resulting from inappropriate use. In such cases, the
guarantee and the right to payment of damages resulting from
inappropriate use are forfeited. The user alone carries all
responsibility of the risks.

Before using Rexroth Indramat products, make sure that all the pre-
requisites for  appropriate use of the products are satisfied:

• Personnel that in any way, shape or form uses our products must first
read and understand the relevant safety instructions and be familiar
with appropriate use.

• If the product takes the form of hardware, then they must remain in
their original state, in other words, no structural changes are permitted.
It is not permitted to decompile software products or alter source
codes.

• Do not mount damaged or faulty products or use them in operation.

• Make sure that the products have been installed in the manner
described in the relevant documentation.
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Areas of Use and Application
SyConPB is a global fieldbus configurator that can be used in combination
with the programming software WinPCL in the system 200. SyConPB is
designed for use in the following application cases:

• Commissioning of PB devices

• Diagnostics

 Note: The fieldbus configurator SyConPB may only be used with the
accessories and parts specified in this document. If a
component has not been specifically named, then it may not
be either mounted or connected. The same applies to cables
and lines.

Operation is only permitted in the specified configurations and
combinations of components using the software and firmware
as specified in the relevant function descriptions.

2.2 Inappropriate Use

Using the fieldbus configurator SyConPB outside of the above-referenced
areas of application or under operating conditions other than described in
the document and the technical data specified is defined as "inappropriate
use".

The fieldbus configurator SyConPB may not be used

• if it is subject to operating conditions that do not meet the above
specified ambient conditions,

• for applications that Rexroth Indramat has not specifically released for
the intended purpose. Please note the specifications outlined in the
general Safety Instructions!
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2.3 Delivery Stipulations for Computer Programs

The copyrights, present and future commercial proprietary rights of all
kinds, as well as all the rights of exploitation to delivered computer
programs – in equipment or separate from it – belong exclusively to the
Supplier.

A computer program may only be used in one single piece of equipment.
Exceptions are commissioning software, which are marked with the
designation -COPY at the end. These can be copied freely within the the
context of regular product usage by the customer.

Every act exceeding the minimum use outlined in the proprietary rights
requires the consent of the Supplier. If a computer program delivered by
the Supplier is not protected by proprietary rights, then the minimum use
stated in the proprietary rights law is declared as agreed upon.

If the Orderer transfers a computer program then he must completely
surrender the program carrier and all copies in their entirety to the
Acquiring Party, or these must be erased. A limitation of use
corresponding to these stipulations (1 through 6) must be agreed upon
with the Acquiring Party.

The Supplier will eliminate any fault in the computer program either by a
circumvention of the fault, which is agreeable to the Orderer, or by
delivering a new program.

All documents and information needed to reconstruct a fault must
accompany the notification of a fault in the computer program.

Otherwise, the general delivery stipulations outlined by INDRAMAT apply.
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3 Safety Instructions for Electric Drives and Controls

3.1 Introduction

Read these instructions before the initial startup of the equipment in order
to eliminate the risk of bodily harm or material damage. Follow these
safety instructions at all times.

Do not attempt to install or start up this equipment without first reading all
documentation provided with the product. Read and understand these
safety instructions and all user documentation of the equipment prior to
working with the equipment at any time. If you do not have the user
documentation for your equipment, contact your local Rexroth Indramat
representative to send this documentation immediately to the person or
persons responsible for the safe operation of this equipment.

If the equipment is resold, rented or transferred or passed on to others,
then these safety instructions must be delivered with the equipment.

WARNING

Improper use of this equipment, failure to follow
the safety instructions in this document or
tampering with the product, including disabling
of safety devices, may result in material
damage, bodily harm, electric shock or even
death!

3.2 Explanations

The safety instructions describe the following degrees of hazard
seriousness in compliance with ANSI Z535. The degree of hazard
seriousness informs about the consequences resulting from non-
compliance with the safety instructions.

Warning symbol with signal
word

Degree of hazard seriousness according
to ANSI

DANGER

Death or severe bodily harm will occur.

WARNING

Death or severe bodily harm may occur.

CAUTION

Bodily harm or material damage may occur.

Fig. 3-1: Hazard classification (according to ANSI Z535)
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3.3 Hazards by Improper Use

DANGER

High voltage and high discharge current!
Danger to life or severe bodily harm by electric
shock!

DANGER

Dangerous movements! Danger to life, severe
bodily harm or material damage by
unintentional motor movements!

WARNING

High electrical voltage due to wrong
connections! Danger to life or bodily harm by
electric shock!

WARNING

Health hazard for persons with heart
pacemakers, metal implants and hearing aids in
proximity to electrical equipment!

CAUTION

Surface of machine housing could be extremely
hot! Danger of injury! Danger of burns!

CAUTION

Risk of injury due to improper handling! Bodily
harm caused by crushing, shearing, cutting and
mechanical shock or incorrect handling of
pressurized systems!

CAUTION

Risk of injury due to incorrect handling of
batteries!
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3.4 General Information

• Rexroth Indramat GmbH is not liable for damages resulting from
failure to observe the warnings provided in this documentation.

• Read the operating, maintenance and safety instructions in your
language before starting up the machine. If you find that you cannot
completely understand the documentation for your product, please ask
your supplier to clarify.

• Proper and correct transport, storage, assembly and installation as
well as care in operation and maintenance are prerequisites for optimal
and safe operation of this equipment.

• Only persons who are trained and qualified for the use and operation
of the equipment may work on this equipment or within its proximity.

• The persons are qualified if they have sufficient knowledge of the
assembly, installation and operation of the equipment as well as an
understanding of all warnings and precautionary measures noted in these
instructions.

• Furthermore, they must be trained, instructed and qualified to
switch electrical circuits and equipment on and off in accordance with
technical safety regulations, to ground them and to mark them according
to the requirements of safe work practices. They must have adequate
safety equipment and be trained in first aid.

• Only use spare parts and accessories approved by the manufacturer.

• Follow all safety regulations and requirements for the specific
application as practiced in the country of use.

• The equipment is designed for installation in industrial machinery.

• The ambient conditions given in the product documentation must be
observed.

• Use only safety features and applications that are clearly and explicitly
approved in the Project Planning Manual.
For example, the following areas of use are not permitted: construction
cranes, elevators used for people or freight, devices and vehicles to
transport people, medical applications, refinery plants, transport of
hazardous goods, nuclear applications, applications sensitive to high
frequency, mining, food processing, control of protection equipment (also
in a machine).

• The information given in the documentation of the product with regard
to the use of the delivered components contains only examples of
applications and suggestions.
The machine and installation manufacturer must

• make sure that the delivered components are suited for his
individual application and check the information given in this
documentation with regard to the use of the components,

• make sure that his application complies with the applicable safety
regulations and standards and carry out the required measures,
modifications and complements.

• Startup of the delivered components is only permitted once it is sure
that the machine or installation in which they are installed complies with
the national regulations, safety specifications and standards of the
application.

• Operation is only permitted if the national EMC regulations for the
application are met.
The instructions for installation in accordance with EMC requirements can
be found in the documentation "EMC in Drive and Control Systems".
The machine or installation manufacturer is responsible for compliance
with the limiting values as prescribed in the national regulations.
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• Technical data, connections and operational conditions are specified in
the product documentation and must be followed at all times.

3.5 Protection Against Contact with Electrical Parts

Note: This section refers to equipment and drive components with
voltages above 50 Volts.

Touching live parts with voltages of 50 Volts and more with bare hands or
conductive tools or touching ungrounded housings can be dangerous and
cause electric shock. In order to operate electrical equipment, certain
parts must unavoidably have dangerous voltages applied to them.

 
DANGER

High electrical voltage! Danger to life, severe
bodily harm by electric shock!
⇒ Only those trained and qualified to work with or on

electrical equipment are permitted to operate, maintain
or repair this equipment.

⇒ Follow general construction and safety regulations when
working on high voltage installations.

⇒ Before switching on power the ground wire must be
permanently connected to all electrical units according
to the connection diagram.

⇒ Do not operate electrical equipment at any time, even
for brief measurements or tests, if the ground wire is not
permanently connected to the points of the components
provided for this purpose.

⇒ Before working with electrical parts with voltage higher
than 50 V, the equipment must be disconnected from
the mains voltage or power supply. Make sure the
equipment cannot be switched on again unintended.

⇒ The following should be observed with electrical drive
and filter components:

⇒ Wait five (5) minutes after switching off power to allow
capacitors to discharge before beginning to work.
Measure the voltage on the capacitors before beginning
to work to make sure that the equipment is safe to
touch.

⇒ Never touch the electrical connection points of a
component while power is turned on.

⇒ Install the covers and guards provided with the
equipment properly before switching the equipment on.
Prevent contact with live parts at any time.

⇒ A residual-current-operated protective device (RCD)
must not be used on electric drives! Indirect contact
must be prevented by other means, for example, by an
overcurrent protective device.

⇒ Electrical components with exposed live parts and
uncovered high voltage terminals must be installed in a
protective housing, for example, in a control cabinet.
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To be observed with electrical drive and filter components:

DANGER

High electrical voltage on the housing!
High leakage current! Danger to life, danger of
injury by electric shock!
⇒ Connect the electrical equipment, the housings of all

electrical units and motors permanently with the safety
conductor at the ground points before power is
switched on. Look at the connection diagram. This is
even necessary for brief tests.

⇒ Connect the safety conductor of the electrical
equipment always permanently and firmly to the
supply mains. Leakage current exceeds 3.5 mA in
normal operation.

⇒ Use a copper conductor with at least 10 mm² cross
section over its entire course for this safety conductor
connection!

⇒ Prior to startups, even for brief tests, always connect
the protective conductor or connect with ground wire.
Otherwise, high voltages can occur on the housing
that lead to electric shock.

3.6 Protection Against Electric Shock by Protective Low
Voltage (PELV)

All connections and terminals with voltages between 0 and 50 Volts on
Rexroth Indramat products are protective low voltages designed in
accordance with international standards on electrical safety.

WARNING

High electrical voltage due to wrong
connections! Danger to life, bodily harm by
electric shock!
⇒ Only connect equipment, electrical components and

cables of the protective low voltage type (PELV =
Protective Extra Low Voltage) to all terminals and
clamps with voltages of 0 to 50 Volts.

⇒ Only electrical circuits may be connected which are
safely isolated against high voltage circuits. Safe
isolation is achieved, for example, with an isolating
transformer, an opto-electronic coupler or when
battery-operated.  

3.7 Protection Against Dangerous Movements

Dangerous movements can be caused by faulty control of the connected
motors. Some common examples are:

• improper or wrong wiring of cable connections

• incorrect operation of the equipment components

• wrong input of parameters before operation

• malfunction of sensors, encoders and monitoring devices

• defective components

• software or firmware errors
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Dangerous movements can occur immediately after equipment is
switched on or even after an unspecified time of trouble-free operation.

The monitoring in the drive components will normally be sufficient to avoid
faulty operation in the connected drives. Regarding personal safety,
especially the danger of bodily injury and material damage, this alone
cannot be relied upon to ensure complete safety. Until the integrated
monitoring functions become effective, it must be assumed in any case
that faulty drive movements will occur. The extent of faulty drive
movements depends upon the type of control and the state of operation.

 
DANGER

Dangerous movements! Danger to life, risk of
injury, severe bodily harm or material damage!
⇒ Ensure personal safety by means of qualified and

tested higher-level monitoring devices or measures
integrated in the installation. Unintended machine
motion is possible if monitoring devices are disabled,
bypassed or not activated.

⇒ Pay attention to unintended machine motion or other
malfunction in any mode of operation.

⇒ Keep free and clear of the machine’s range of motion
and moving parts. Possible measures to prevent
people from accidentally entering the machine’s range
of motion:

- use safety fences

- use safety guards

- use protective coverings

- install light curtains or light barriers

⇒ Fences and coverings must be strong enough to
resist maximum possible momentum, especially if
there is a possibility of loose parts flying off.

⇒ Mount the emergency stop switch in the immediate
reach of the operator. Verify that the emergency stop
works before startup. Don’t operate the machine if the
emergency stop is not working.

⇒ Isolate the drive power connection by means of an
emergency stop circuit or use a starting lockout to
prevent unintentional start.

⇒ Make sure that the drives are brought to a safe
standstill before accessing or entering the danger
zone. Safe standstill can be achieved by switching off
the power supply contactor or by safe mechanical
locking of moving parts.

⇒ Secure vertical axes against falling or dropping after
switching off the motor power by, for example:

- mechanically securing the vertical axes

- adding an external braking / arrester / clamping
mechanism

- ensuring sufficient equilibration of the vertical axes

The standard equipment motor brake or an external
brake controlled directly by the drive controller are
not sufficient to guarantee personal safety!
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⇒ Disconnect electrical power to the equipment using a
master switch and secure the switch against
reconnection for:

- maintenance and repair work

- cleaning of equipment

- long periods of discontinued equipment use

⇒ Prevent the operation of high-frequency, remote
control and radio equipment near electronics circuits
and supply leads. If the use of such equipment cannot
be avoided, verify the system and the installation for
possible malfunctions in all possible positions of
normal use before initial startup. If necessary, perform
a special electromagnetic compatibility (EMC) test on
the installation.

3.8 Protection Against Magnetic and Electromagnetic Fields
During Operation and Mounting

Magnetic and electromagnetic fields generated near current-carrying
conductors and permanent magnets in motors represent a serious health
hazard to persons with heart pacemakers, metal implants and hearing
aids.

WARNING

Health hazard for persons with heart
pacemakers, metal implants and hearing aids in
proximity to electrical equipment!
⇒ Persons with heart pacemakers, hearing aids and

metal implants are not permitted to enter the following
areas:

- Areas in which electrical equipment and parts are
mounted, being operated or started up.

- Areas in which parts of motors with permanent
magnets are being stored, operated, repaired or
mounted.

⇒ If it is necessary for a person with a heart pacemaker
to enter such an area, then a doctor must be
consulted prior to doing so. Heart pacemakers that
are already implanted or will be implanted in the
future, have a considerable variation in their electrical
noise immunity. Therefore there are no rules with
general validity.

⇒ Persons with hearing aids, metal implants or metal
pieces must consult a doctor before they enter the
areas described above. Otherwise, health hazards will
occur.
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3.9 Protection Against Contact with Hot Parts

CAUTION

Housing surfaces could be extremely hot!
Danger of injury! Danger of burns!
⇒ Do not touch housing surfaces near sources of heat!

Danger of burns!
⇒ After switching the equipment off, wait at least ten (10)

minutes to allow it to cool down before touching it.
⇒ Do not touch hot parts of the equipment, such as

housings with integrated heat sinks and resistors.
Danger of burns!

3.10 Protection During Handling and Mounting

Under certain conditions, incorrect handling and mounting of parts and
components may cause injuries.

CAUTION

Risk of injury by incorrect handling! Bodily
harm caused by crushing, shearing, cutting and
mechanical shock!
⇒ Observe general installation and safety instructions

with regard to handling and mounting.
⇒ Use appropriate mounting and transport equipment.
⇒ Take precautions to avoid pinching and crushing.
⇒ Use only appropriate tools. If specified by the product

documentation, special tools must be used.
⇒ Use lifting devices and tools correctly and safely.
⇒ For safe protection wear appropriate protective

clothing, e.g. safety glasses, safety shoes and safety
gloves.

⇒ Never stand under suspended loads.
⇒ Clean up liquids from the floor immediately to prevent

slipping.
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3.11 Battery Safety

Batteries contain reactive chemicals in a solid housing. Inappropriate
handling may result in injuries or material damage.

CAUTION

Risk of injury by incorrect handling!
⇒ Do not attempt to reactivate discharged batteries by

heating or other methods (danger of explosion and
cauterization).

⇒ Never charge non-chargeable batteries (danger of
leakage and explosion).

⇒ Never throw batteries into a fire.
⇒ Do not dismantle batteries.
⇒ Do not damage electrical components installed in the

equipment.

Note: Be aware of environmental protection and disposal! The
batteries contained in the product should be considered as
hazardous material for land, air and sea transport in the sense
of the legal requirements (danger of explosion). Dispose
batteries separately from other waste. Observe the legal
requirements in the country of installation.

3.12 Protection Against Pressurized Systems

Certain motors and drive controllers, corresponding to the information in
the respective Project Planning Manual, must be provided with
pressurized media, such as compressed air, hydraulic oil, cooling fluid
and cooling lubricant supplied by external systems. Incorrect handling of
the supply and connections of pressurized systems can lead to injuries or
accidents. In these cases, improper handling of external supply systems,
supply lines or connections can cause injuries or material damage.

 CAUTION

Danger of injury by incorrect handling of
pressurized systems !
⇒ Do not attempt to disassemble, to open or to cut a

pressurized system (danger of explosion).
⇒ Observe the operation instructions of the respective

manufacturer.
⇒ Before disassembling pressurized systems, release

pressure and drain off the fluid or gas.
⇒ Use suitable protective clothing (for example safety

glasses, safety shoes and safety gloves)
⇒ Remove any fluid that has leaked out onto the floor

immediately.

Note: Environmental protection and disposal! The media used in the
operation of the pressurized system equipment may not be
environmentally compatible. Media that are damaging the
environment must be disposed separately from normal waste.
Observe the legal requirements in the country of installation.



3-10 Safety Instructions for Electric Drives and Controls SyConPB

           DOK-CONTRL-SYCON****-DP-AW02-EN-P

Notes
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4 Installation

4.1 System Requirements

• PC with 486-, Pentium processor or higher

• Windows 95, Windows 98, Windows NT 4.0

• Free disk space:  30 - 80 mbytes

• CD ROM drive

• RAM: min. 16 mbytes

• Graphic resolution: min. 800 x 600 pixel

• Windows 95: Service Pack 1

• Windows NT: Service Pack 3

• Keyboard and Mouse

4.2 Software Installation

Close all application programs on the system!

Insert the CD in the local CD ROM drive. The installation program will
start by itself (Autostart enabled). Otherwise change into the root directory
on the CD and start Autorun.exe (Autostart disabled).

Note: Administrator privileges are required on Windows NT systems
for installation!

The installation program asks for the components you want to install.
Answer these questions with Yes or No.

It will install

• System configurator SyConPB (Configuration and diagnostic tool)

• CIF Device Driver (Device Driver for access to the CIF)
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4.3 Installation of the System Configurator SyConPB

Follow the instructions of the installation program by selecting the fieldbus
system to be installed and answer all the questions with OK or NEXT.

The installation program offers the following selections:

Selection Default Settings Meaning

Directory C:\Programs\Hilscher\SyCon Directory for Installation of the system configurator and its
components

DeviceNet Selected Program DLL and components of the fieldbus system or the
protocol

INTERBUS Selected

PROFIBUS Selected

CIF Device
Driver

Selected
C:\Programs\CIF Device Driver

CIF Device Driver

Program Menu SyCon System Configurator Folder under Start > Programs

Fig. 4-1: Selection during installation

The installation program copies the program files, GSD or EDS files and
bitmaps to the PC. Finally,

• system DLLs,

• the application,

• OLE controls

and

• ODBC components

are entered into the registry.
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5 Configuration Sequence

5.1 Hardware Configuration

Before you can start-up the DPM_PC104 or the DPS_PC104, you must
check if the configured memory areas and interrupts are not assigned to
other devices. When using WindowsNT check this under
Programs/Management/WindowsNT Diagnostics/Resources to recognize
and eliminate errors of this kind.

Select from the following table the communication that you want to use.
The configuration steps are described in the given chapter.

Communication Device Device Described in Chapter Page

PROFIBUS DP INDRAMAT
DP Master

Any
DP Slave

Configuration INDRAMAT-Master DPM_104 to any
DP Slave

5-2

Any
DP Master

Hilscher
DP Slave

Configuration Hilscher DP Slave to any DP Master 5-3

Hilscher
DP Master

Hilscher
DP Slave

Configuration Hilscher DP Master to Hilscher DP Slave 5-4

Fig. 5-1: Overview Communication
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5.2 Configuration INDRAMAT Master DPM_104 to Any
DP Slave

The following table describes the steps to configure an INDRAMAT
Master DPM_104 to any DP Slave as it is typical for many cases.

# Action Menu in the System Configurator Detail Information in
Chapter

Page

1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS
Configuration

6-1

2 Copy GSD file of the DP Slave,
if the slave is not in the
selection list

File > Copy GSD GSD Files 6-1

3 Choose Hilscher DP Master
and provide bus address

Insert > Master Insert Master 6-2

4 Choose DP Slave and provide
bus address

Insert > Slave Insert DP Slave 6-5

5 Assign the input and output
modules

Mark the slave (left mouse click), then

Settings > Slave Configuration

Slave Configuration  6-6

6 Assign the offset addresses

7 Assign the DP Slave parameter
data, if the Slave needs
parameter data

Mark the slave (left mouse click), then

Settings > Parameter Data

Parameter Data  7-18

8 Set the bus parameter Mark the master (left mouse click), then

Settings > Bus Parameters

Bus Parameters 7-5

9 Set device assignment if no
automatic assignment has
occurred

Mark the master (left mouse click), then

Settings > Device Assignment

Device Assignment 7-1

10 Save project File > Save Save and Save As 9-1

11 Download Mark the master (left mouse click), then

Online > Download

Downloading the
Configuration

8-1

12 Live list Mark the master (left mouse click), then

Online > Live List

Live List 8-3

13 Start debugger Mark the master (left mouse click), then

Online > Start Debug Mode

Debug Mode 8-5

14 Device diagnostic Mark the slave (left mouse click), then

Online > Device Diagnostic

Device Diagnostic 8-6

15 Stop debugger Online > Stop Debug Mode Debug Mode 8-5

16 Global diagnostic Mark the master (left mouse click), then

Online > Global State Field

Global State Field 8-10

17 Transfer user data:

Write output, read input

Mark the master (left mouse click), then

Online > I/O Monitor

I/O Monitor

Or: I/O Watch

8-48
8-48

Fig. 5-2: Steps for the configuration of the INDRAMAT Master DPM_104 to any
DP Slave
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5.3 Configuration Hilscher DP Slave to Any DP Master

The following table describes the steps to configure a Hilscher DP Slave
to any DP Master as it is typical for many cases.

# Action Menu in the System Configurator Detail Information in
Chapter

Page

1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS
Configuration

6-1

2 Choose a Hilscher DP Master
and provide bus address

Insert > Master Insert Master 6-2

3 Choose Hilscher DP Slave and
provide bus address

Insert > Slave Insert DP Slave 6-5

4 Assign the input and output
modules (*1)

Mark the slave (left Mouse click), then

Settings > Slave Configuration

Slave Configuration 6-6

5 Set device assignment if no
automatic assignment has
occurred

Mark the slave (left Mouse click), then

Settings > Device Assignment

Device Assignment 7-1

6 Save project File > Save Save and Save As 9-1

7 Download Mark the slave (left Mouse click), then

Online > Download

Downloading the
Configuration

8-1

8 Configuration diagnostic Mark the slave (left Mouse click), then

Online > Extended Device Diagnostic
> SPC3CTRL Slave Config

Extended Device Diagnostic
SPC3CTRL Slave Config

8-11

9 Configuration diagnostic Mark the slave (left Mouse click), then

Online > Extended Device Diagnostic
> SPC3CTRL Master Config

Extended Device Diagnostic
SPC3CTRL Master Config

8-11

10 Transfer user data:

Write output, read input

Mark the slave (left Mouse click), then

Online > I/O Monitor

I/O Monitor

(*2)

8-48

Fig. 5-3: Steps for the configuration Hilscher DP Slave to any DP Master

Remark (*1): The offset addresses assigned in the slave configuration are
always related to the Hilscher DP Master and have no meaning here.

Remark (*2): Alternatively the CIF Device Driver test program can be
used for the test. After Board Select: Data Transfer > I/O Data >
DevExchangeIO.
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5.4 Configuration Hilscher DP Master to Hilscher DP Slave

The following table describes the steps to configure a Hilscher DP Master
to a Hilscher DP Slave as it is typical for many cases.

# Action Menu in the System Configurator Detail Information in
Chapter

Page

1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS
Configuration

6-1

2 Choose Hilscher DP Master
and provide bus address

Insert > Master Insert Master 6-2

3 Choose Hilscher DP Slave and
provide bus address

Insert > Slave Insert DP Slave 6-5

4 Assign the input and output
modules (*1)

Mark the slave (left Mouse click), then

Settings > Slave Configuration

Slave Configuration 6-6

5 Assign the offset addresses

6 Set the bus parameter Mark the master (left Mouse click), then

Settings > Bus Parameters

Bus Parameters 7-5

7 Set device assignment for the
master if no automatic
assignment has occurred

Mark the master (left Mouse click), then

Settings > Device Assignment

Device Assignment 7-1

8 Set device assignment for the
slave if no automatic
assignment has occurred

Mark the slave (left Mouse click), then

Settings > Device Assignment

Device Assignment 7-1

9 Save project File > Save Save and Save As 9-1

10 Download to the master Mark the master (left Mouse click), then

Online > Download

Downloading the
Configuration

8-1

11 Download to the slave Mark the slave (left Mouse click), then

Online > Download

Downloading the
Configuration

8-1

12 Live list Mark the master (left Mouse click), then

Online > Live List

Live List 8-3

13 Start debugger Mark the master (left Mouse click), then

Online > Start Debug Mode

Debug Mode 8-5

14 Device diagnostic Mark the slave (left Mouse click), then

Online > Device Diagnostic

Device Diagnostic 8-6

15 Stop debugger Online > Stop Debug Mode Debug Mode 8-5

16 Global diagnostic Mark the master (left Mouse click), then

Online > Global State Field

Global State Field 8-10

17 Transfer user data:

Write output, read input

Mark the master (left Mouse click), then

Online > I/O Monitor

I/O Monitor
Or: I/O Watch

(*2)

8-48
8-48

Fig. 5-4: Steps for Configuration Hilscher DP Master to Hilscher DP Slave

Remark (*1): The offset addresses assigned in the slave configuration are
always related to the Hilscher DP Master.

Remark (*2): Alternatively the CIF Device Driver test program can be
used for the test. After Board Select: Data Transfer > I/O Data >
DevExchangeIO.



SyConPB Configuration of PROFIBUS with SyConPB 6-1

DOK-CONTRL-SYCON****-DP-AW02-EN-P           

6 Configuration of PROFIBUS with SyConPB

6.1 Setting up the PROFIBUS Configuration

To create a new configuration, choose the File > New menu. This will
offer a selection list of fieldbus systems. Choose the PROFIBUS. If only
the PROFIBUS fieldbus system is to be installed, then the configuration
window will open directly.

The name of the configuration file can be allocated when the configuration
is ended or with File > Save As.

6.2 GSD Files

GSD (Electronic data sheet of a device) files contain and describe the
functions and characteristics of the PROFIBUS devices. The abbreviation
GSD means ’Gerätestammdaten' (Device Base Files). All the available
GSD files together make up the device database.

When the program is started, the system configurator automatically
retrieves all the GSD files stored in the GSD directory. The device names
are placed into an internal list. During the configuration, the device-
specific data is retrieved directly from the GSD files.

If a DP Slave device does not appear on the selection list, then a
corresponding GSD file can be copied into the GSD directory with File >
Copy GSD. Another possibility is to copy the GSD file into the SyCon
GSD directory with Windows Explorer and then retrieve the GSD files into
the GSD directory with Settings > Path and OK.

The GSD files can be viewed with the Tools > GSD Viewer menu.

pb_4_01d.bmp

Fig. 6-1: GSD files and bitmap directory

• INDRAMAT devices: The GSD files for INDRAMAT devices
                                              are already included and are installed.

• Other devices: The respective device manufacturer
                                              provides the GSD files for other devices.

The GSD files of many vendors are available on the PROFIBUS user
organization home page.

http://www.profibus.com

Note: GSD files are only used for PROFIBUS DP!

The GSD directory is adjustable. In order to alter the directory from a
previous setting in another directory, use the Settings > Path menu. All
GSD files must be placed in this directory.
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6.3 Master

Insert Master
In order to insert a (Hilscher) master into the configuration, choose the
Insert > Master menu, in order to open the selection window, or click on
the symbol:

The mouse pointer automatically changes into the ’Insert Master’ pointer.
Click on the position where the Master is to be inserted. The dialog box,
from which one or more masters can be chosen, opens.

pb_4_04d.bmp

Fig. 6-2: Insert > Master

This example shows a CIF 50-PB that is inserted with the Station
address 1 and the description PC_Master. The description must not
contain any special characters (blank characters etc.).



SyConPB Configuration of PROFIBUS with SyConPB 6-3

DOK-CONTRL-SYCON****-DP-AW02-EN-P           

Master Configuration
The configuration specific to the master is carried out in the following
window.

Set the focus on the master (left mouse click) and then select the
Settings > Master Configuration menu

or

a double click on the symbol of the master to be configured will open the
following window.

pb_4_05d.bmp

Fig. 6-3: Master configuration

The following can be set in this ’Master Configuration’ window:

• The Station address of the master

• A (symbolic) Description of the master

• Selection of the master as the Actual Master (for example, for
carrying out a Download)

For PROFIBUS DP one can

• open the DP Master Settings window

• activate or deactivate the automatic addressing (Auto addressing) for
this DP Master.
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Auto Configuration (PROFIBUS DP)
The ’Auto Configuration’ can be used to configure a slave. The parameter
data cannot be retrieved from a PROFIBUS DP Slave. These, if the slave
requires parameter data, can only be provided by the user.

The following is the procedure for ’Auto Configuration’:

# Action Menu in the System Configurator Detail Information in Chapter Page

1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS
Configuration

6-1

2 Copy GSD file of the DP Slave,
if the slave is not in the
selection list

File > Copy GSD GSD Files 6-1

3 Choose Hilscher DP Master
and provide Bus address

Insert > Master Insert Master 6-2

4 Choose DP Slave and provide
bus address

Insert > Slave Insert DP Slave 6-5

5 Set the bus parameter Mark the master (left Mouse click),
then
Settings > Bus Parameters

Bus Parameters  7-5

6 Set device assignment if no
automatic assignment has
occurred

Mark the master (left Mouse click),
then
Settings > Device Assignment

Device Assignment  7-1

7 Save project File > Save Save and Save As 9-1

8 Download Mark the master (left Mouse click),
then
Online > Download

Downloading the Configuration 8-1

9 Live list Mark the master (left Mouse click),
then
Online > Live List

Live List 8-3

10 Start debugger Mark the master (left Mouse click),
then
Online > Start Debug Mode

Debug Mode 8-5

11 Device diagnostic Mark the slave (left Mouse click),
then
Online > Device Diagnostic

Device Diagnostic 8-6

12 Compare configuration Compare Configuration -

13 Automatic configuration Automatic Configuration -

14 Stop debugger Online > Stop Debug Mode Debug Mode 8-5

15 Save project File > Save Save and Save As 9-1

16 Download Mark the master (left Mouse click),
then
Online > Download

Downloading the Configuration 8-1

17 Start debugger Mark the master (left Mouse click),
then
Online > Start Debug Mode

Debug Mode 8-5

18 Device diagnostic Mark the slave (left Mouse click),
then
Online > Device Diagnostic

Device Diagnostic 8-6

19 Stop debugger Online > Stop Debug Mode Debug Mode 8-5

20 Transfer user data:

Write output, read input

Mark the master (left Mouse click),
then
Online > I/O Monitor

I/O Monitor

Or: I/O Watch

8-48
8-48

Fig. 6-4: Auto configuration (PROFIBUS DP)
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6.4 DP Slave

Insert DP Slave
In order to insert a PROFIBUS DP Slave into the configuration, choose
the Insert > Slave menu to open the selection window, or click on the
symbol:

The mouse pointer automatically changes to the Insert Slave pointer.
Click on the position where the slave is to be inserted. The dialog box,
from which one or more slaves can be selected, is opened.

pb_4_08d.bmp

Fig. 6-5: Insert > Slave

The list on the left displays for selection all the slave devices whose GSD
files have been put in the GSD directory. A filter can be used to limit the
selection list to Slave type and Vendor (manufacturer). Further
information on a Slave is shown below the selection list (Available
Slaves) when it is selected (a mouse click). The slave appears on the
right-hand list with a mouse click or with the Add button. All devices in the
right-hand list are assigned to the current Master that is also shown in
this window. If the Slaves in the right-hand list are chosen one after the
other (a mouse click), then every slave can be allocated a Station
address as well as a name in the Description field.

For every slave accepted into the right-hand list, the station address count
is automatically raised by one but can be overwritten by the user in the
Station address field.

Note: It is permissible to choose a slave several times. However,
each slave must possess its own (unique) station address in
order to distinguish it in the network.
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Slave Configuration
First click the symbol of the slave with the left mouse button and then
choose the Settings > Slave Configuration menu

or

open the slave configuration window by means of double clicking on the
PROFIBUS DP Slave device.

The slave-specific configuration is carried out in this window. Here, the
modules and their addresses are allocated in the process data memory in
the Master. Note that the address must agree with that in the PC
application.

Note: The information of the offset addresses refers to the
addressing of the data in the master! The address information
does not refer to the addressing of the data in the slave! The
slave organizes its own data addressing.

There are two types of slaves. A simple slave possesses a fixed data
length. The data length of a modular slave (e.g. DPS_PC014) is
configurable. A modular slave can be understood to be a combination of
simple slave with a station address.

pb_4_09d.bmp

Fig. 6-6: Slave configuration
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The selection list (upper list) shows all possible modules of the slave. In
the case of a simple slave, one module is shown and this is automatically
copied into the configuration list (lower list). In the case of a modular
slave, the user must select the required modules and transfer these by
means of a double click or transfer it using the Append Module button
into the configuration list (lower list).

If a module consists of several sub-modules, then each sub-module is
depicted in the configuration list (lower list) in a separate row. This is
displayed by the number in the Slot column. The slot count is started with
1. The Index column shows a sequential number for sub-modules.

For configuration of the module (selection of the module) of a slave,
proceed as follows:

• Transfer all the required modules from the selection list (upper list) into
the configuration list (lower list). The sequence of the modules in the
configuration list (lower list) is important and must be in agreement
with the slave. Typically, the sequence follows the actual physical
sequence. There are slaves to which this rule does not apply and
where first analog modules and then digital modules must be entered,
independent of their actual sequence.

• In the configuration list (lower list) allocate the address of each module
to the process depiction memory. The address is entered separately in
the Type and Addr columns for inputs and outputs.

The I/O addresses can be allocated by the user or can be automatically
assigned by SyCon. For this purpose Auto addressing must be activated
or deactivated in the Master Configuration window. When the Auto
Addressing is active, then the addresses will be allocated beginning with 0
and incremented in accordance with the entry sequence of the Slaves
before downloading and can be viewed and checked in the View >
Address Table. When the Auto addressing is deactivated, then only the
address 0 is shown in the I Addr or O Addr and must be overwritten by
the user.

Depending on the Addressing mode, which can be set in the DP Master
Settings, the addresses are either Byte or Word addresses. For further
details of this, see the description in the “Address Mode” chapter.

The DP Slaves utilize the Watchdog Control setting in order to detect
communication errors to the assigned DP Master. When the DP Slave
finds an interruption of an already operational communication, defined by
a watchdog time, then the slave carries out an independent 'Reset' and
places the outputs into the secure condition.

Caution: When the monitoring by means of the Watchdog Control has
been deactivated, it is possible that the outputs are not reset by the slave,
even though the communication has been interrupted.

If Activate Device in the Current Configuration is selected, then the
process memory for this slave is occupied in the master and at the bus a
data exchange is carried out from the bus to this slave. If this setting is
switched off, then the process memory for this slave is occupied in the
master and at the bus no data exchange is carried out from the bus to this
slave.
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Inserting Predefined Device – PDD
In order to insert predefined devices, choose Insert > PDD. This function
is used for simple copying or re-using already configured devices. Before
this function can be used, a PDD export must be carried out as described
in chapter PDD Export from page 9-39-2 on.

pb_4_10d.bmp

Fig. 6-7: Inserting predefined device – PDD (1)

Select the PDD file and then Open. The following window appears.

pb_4_11d.bmp

Fig. 6-8: Inserting predefined device – PDD (2)

Select the device or devices of the Found predefined devices (left-hand
side) and pull this over to the Selected predefined devices (right-hand
side) and release the left mouse button (drag and drop).
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The following picture will appear:

pb_4_12d.bmp

Fig. 6-9: Inserting predefined device  –  PDD (3)

The figure shows a device with the description Slave2 consisting of two
modules with the description Module1 and Module2.

Choose Ok in order to insert the device into the configuration.

Subsequently the station address of the device can be altered.
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7 Settings

7.1 Device Assignment

The device assignment setting determines how the system configurator
communicates with the device. This is set in the device arrangement via
the menu Settings > Device Assignment.

CIF Serial Driver:

• CIF Serial Driver: The system configurator communicates with master
or respectively the slave interface via a serial connection. Thereby, a
COM interface of the PC must be connected via a diagnostic interface
X74 of the master (DPM01_PC104) or the slave X79 (DPS01_PC104)
with the diagnostic cable IKS106.

CIF Device Driver:

• CIF Device Driver: The system configurator communicates with the
Hilscher device over the Dual-Port Memory of the device.

• This communication is utilized when the system configurator is used
on the same PC on which the Hilscher device (CIF) is installed.

• The CIF Device Driver must have been installed.

CIF Serial Driver
The serial driver supports COM1 to COM 4, in order to communicate over
the diagnostic interface with the device.

The device is selected via Settings > Device Assignment.

pb_5_04d.bmp

Fig. 7-1: Driver selection – CIF Serial Driver

Choose the CIF Serial Driver and then OK, in order to select the CIF
Serial Driver.
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The connection must first be established using the switching surface
Connect COM1 or Connect COM2 or Connect COM3 or Connect
COM4. They can be used depending on which COM interfaces are
installed and free on the PC.

The system configurator sends a request to the corresponding COM
interface and polls the Firmware of the device. A display of the Firmware
will indicate when a device is connected. In the other case, a timeout error
(-51) appears, which will state that no device is connected.

pb_5_05d.bmp

Fig. 7-2: CIF Serial Driver – device assignment

The error number –20 indicates that this COM interface is not available or
not free.
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CIF Device Driver
The Device driver supports up to four devices in one PC and they are
accessed via the Dual-Port Memory.

Note: At the moment, this way of communication is not supported.

The Device driver is selected via Settings > Device Assignment.

pb_5_01d.bmp

Fig. 7-4: Driver Select – CIF Device Driver

Choose CIF Device Driver and then OK, in order to select the CIF
Device Driver. If the PC has a suitable device, a query will appear asking
weather this device is to be assigned now.

pb_5_02d.bmp

Fig. 7-5: Auto Assignment

 The device is assigned with Yes. With No, no assignment is made.
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pb_5_03d.bmp

Fig. 7-6: CIF Device driver – device assignment
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7.2  Bus Parameters

The bus parameters are the foundations of a functioning data exchange.
This section contains information for setting the bus parameters as well
as the descriptions of the individual parameters.

Basic Rule: The bus Parameters must be set the same for all
devices. The station address, on the other hand, must
be different from device to device.

For PROFIBUS Master devices (PROFIBUS DP) the bus parameters are
set.

Most of the PROFIBUS DP Slave devices:

• Recognize the baud rate automatically and adapt themselves to it.
This is especially the case when the ASIC SPC3 is used.

• However, there are also PROFIBUS DP Slave devices, in which the
bus parameters must be set by the user.

 Setting the Bus Parameters and Profiles

The baud rate can be set in the Settings > Bus Parameters menu.
Furthermore, the optimizing or profile can be selected.

pb_5_08d.bmp

Fig. 7-11: Settings > Bus Parameters

The bus parameters can be viewed with the Settings > Bus Parameters
menu and can be edited by clicking on the Edit button. The Bus
parameters are either editable or not editable depending on the optimizing
or profile.

The optimizing standard provides each baud rate with default bus
parameters for PROFIBUS DP systems.

By changing the settings in the Optimizing field from Standard to User
defined, all bus parameters become editable.
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pb_5_09d.bmp

Fig. 7-12: Editing bus parameters

Caution: The changing of bus parameters can cause communication
interruptions.

Note: The offline bus parameters are displayed. The bus parameters
are only accepted by the Hilscher device after the download of
the configuration.

The Baud rate must be set to be the same for all devices on the Bus. The
result of changing the Baud rate is that all other parameters must be re-
calculated. The system configurator tests whether the Baud rate is
supported by all configured PROFIBUS DP Slave devices, on the basis of
entries in the GSD files. If the system configurator recognizes at least one
device that does not support the selected baud rate, then an error
message will appear.

The highest station address is the highest bus address up to which a
master searches for another master at the bus in order to pass on the
token. This station address must on no account be smaller than the
master station address.

For PROFIBUS DP, the field Access monitoring time is used for entry of
the monitoring time of the slave. If the time chosen for this is too short for
a low baud rate, then it is possible that the slaves will set their outlets to
zero. If the time chosen is too long, it is possible that if an interruption
occurs, the slaves will take a long time to set their outlets to zero.

For PROFIBUS DP, the Auto Clear setting will provide for global error
handling. The DP Master monitors the user data exchange
(DataExchange) to all DP Slaves by means of a timer. If no data
exchange occurs to at least one DP Slave, or an existing data exchange
takes place after the expiration of a monitoring time, and the Auto clear
mode option is ON, then the master leaves the DataExchange and sets
the outlets of all  assigned DP Slaves into a secure condition.
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 Descriptions of the Individual Parameters
 All times for the bus parameters are given in bit times.

 The bit time tBit is the result of the reciprocal of the baud rate:

tBit = 1 / baud rate (baud rate in bit/s)

The conversion from milliseconds into a bit time is shown in the following
equation:

bit time = time [milliseconds] * baud rate

The bus parameters and their meanings:

• Baud rate

Transfer speed: number of bits per second.

Baud rate Bit time (tBit) Max. cable length (type A)

9,6 kbaud 104,2 us 1200 m

19,2 kbaud 52,1 us 1200 m

93,75 kbaud 10,7 us 1200 m

187,5 kbaud 5,3 us 1000 m

500 kbaud 2 us 400 m

1,5 mbaud 666,7 ns 200 m

3 mbaud 333,3 ns 100 m

6 mbaud 166,7 ns 100 m

12 mbaud 83,3 ns 100 m

Fig. 7-14: Baud rates, bit times and cable lengths

Note: The maximum cable length is dependent on the baud rate.

• Minimum station delay of responders (min TSDR)

This is the shortest time period that must elapse before a remote recipient
(responder) may send an acknowledgement of a received query telegram.
The shortest time period between receipt of the last bit of a telegram to
the sending of the first bit of a following telegram.

Value range: 1 .. 65535

• Maximum station delay of responders (max TSDR)

This is the longest time period that must elapse before a sender
(requestor) may send a further query telegram. Greatest time period
between receipt of the last bit of a telegram to the sending of the first bit
of a following telegram.

The sender (requestor, master) must wait at least for this time period after
the sending of an unacknowledged telegram (e.g. broadcast only) before
a new telegram is sent.

Value range: 1 .. 65535

• Slot time (TSL)

"Wait for receipt" – monitoring time of the senders (requestor) of telegram
for the acknowledgement of the recipient (responder). After expiration, a
retry occurs in accordance with the value of "Max. telegram retries".

Value range: 52 .. 65535
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• Quiet time (TQUI)

This is the time delay that occurs for modulators (modulator-trip time) and
repeaters (repeater-switch time) for the change over from sending to
receiving.

Value range: 0 .. 255

• Setup time (TSET)

Minimum period "reaction time" between the receipt of an
acknowledgement to the sending of a new query telegram (reaction) by
the sender (requestor).

Value range: 1 .. 255

• Target rotation time (TTR)

Pre-set nominal token cycling time within which the sender authorization
(token) will cycle around the ring. How much time the master still has
available for sending data telegrams to the slaves is dependent on the
difference between the nominal and the actual token cycling time.

Value range: 1 .. 16.777.215

• GAP update factor (G)

Factor for determining after how many token cycles an added participant
is accepted into the token ring. After expiry of the time period G*TTR, the
station searches to see whether a further participant wishes to be
accepted into the logical ring.

Value range: 1 .. 100

• Max number of telegram retries (Max_Retry_Limit)

Maximum number of repeats in order to reach a station.

Value range: 1 .. 8

• Highest station address (HSA)

Station address of the highest active (master) station.

Value range: 2 .. 126

Further, there are:

• Ready time (TRDY)

This is the time period, after the master has sent out a query, during
which it must be ready for the respective acknowledgement or answer.

• Synchronization time (TSYN)

This is the minimum time that must be available to each device as a rest
condition before it is allowed to accept the start of a query. Is defined at
33 bit times.

The following parameters are applicable only for PROFIBUS DP:

• Data control time (Data_Control_Time)

This parameter defines the time within which the Data_Transfer_List is
updated at least once. After the expiration of this period, the master (class
1) reports its operating condition automatically via the Global_Control
command.

Value range: 1 .. 65535 (time basis 10ms)

• Min slave interval (Min_Slave_Interval)

This parameter defines the minimum time period between two slave list
cycles. The maximum value that the active stations require is always
given.

Value range: 1 .. 65535 (time basis 100us)
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• Access monitoring (TWD)

Access monitoring TWD at the slave ensures that when an interruption of
the DP Master occurs, the outlets are placed in a secure condition after
this time period.

• Poll timeout (Poll_Timeout)

This parameter defines the maximum time period in a master-master
relationship within which the answer must be fetched by the requestor.

Value range: 1 .. 65535 (time basis 1ms)

• TID1 and TID2

This is the time that the sender spends at idle after the receipt of the last
Bit of a telegram on the bus, until the first bit of a new telegram is sent on
the bus.

Depending on the type of the telegram:

TID1 starts after the initiator has received an acknowledgement, answer or
a token telegram.

TID1 = max (TQUI + 2 * TSET + 2 + TSYN, min TSDR).   (*)

TID2 starts after the initiator has sent a telegram that is not acknowledged.

 TID2 = max (TQUI + 2 * TSET + 2 + TSYN, max TSDR).   (*)

These times cannot be set directly, but result from the given calculations.

(*) Depending on the ASIC and baud rate utilized, the TID1 and TID2 can
take on somewhat different values due to the ASIC software.

Rules

For  min TSDR, max TSDR and TSL the following rule applies:

0 < min TSDR < max TSDR < TSL

For TQUI, TRDY  and min TSDR the following rule applies:

                           TQUI < TRDY < min TSDR.

For access monitoring (TWD) and target rotation time (TTR):   

TWD > TTR

For the Data_Control_Time the following rule applies:

            Data_Control_Time > 6 * TWD
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7.3 DP Master

Master Settings
To enter the DP Master settings, choose the Settings > Master Settings
or click with the right mouse button on the corresponding master symbol
and select from the list that opens up. The DP Master Settings is also
available in the Master Configuration window.

The DP Master settings contain parameters that determine the behavior
of the master device as well as the user interface. These settings are only
valid for Hilscher devices and are included in the download of the
configuration.

pb_5_11d.bmp

Fig. 7-15: DP Master settings

• Startup behaviour after system initialisation

When Automatic release of the communication by the device has
been set, the master device starts with the data exchange at the Bus after
the initializing has been ended. When Controlled release of
communication by the application program has been set, the
application program must activate the data exchange at the Bus.

• User program monitoring

The Watchdog time determines how long the device waits for a triggering
of the software watchdog by the application program until it sets the
outputs of the slave devices to zero. This behavior must be activated by
the user program and does not start automatically.

Note: This is not a special PROFIBUS function.
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An example of the use of this function can be a SoftPLC.

• Addressing mode

The addressing mode of the process data image determines how the
addresses (Offsets) of the process data are interpreted. Either of the
addressing modes Byte addresses or Word addresses are possible.
See also details on the next page.

• Storage format (word module)

The storage format determines how the data words are laid down in the
process image. For the word data type it is possible to choose
higher/lower value byte or lower/higher value byte.

• Handshake of the process data

These various types are used for setting the transfer process of the
process data for the master. The choice of which type is used is important
for the correct data exchange between the application program and the
device. A detailed description is provided in the manual for the toolkit or
the manual for the device driver.

• Hardware parameter

This parameter displays the size of the Dual-Port Memory. The size for
process data is the displayed size less 1 kbyte. E.g. 8 kbyte - 1 kbyte = 7
kbyte for process data.
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Addressing Mode
The addresses in the configuration of the nodes define the starting point
of the data in the process depiction. This can work in a Word or Byte
oriented method by means of the Addressing mode parameter.

Byte addresses The process depiction has a byte structure and each
byte has its own address.

Word addresses The process depiction has a Word structure and 
each Word has its own address.

This has nothing to do with the physical size of the Dual-Port Memory –
this is always byte-oriented! When the application makes a Word access,
it is automatically divided by the PC into two sequential byte accesses.

The following table shows the different storing of the various data types in
the Byte- or Word-oriented process image:

IEC address IEC address Offset address in the Data in the Output to an I/O module

in byte mode in Word
mode

Dual-Port Memory process image

QB 0 QB 0 0 0000 0000

QB 1 1 0000 0000

QB 2 QB 1 2 1110 0010

Output of QB2 / QB1 to a single byte module:
D7 D6 D5 D4 D3 D2 D1 D0
  1    1    1   0   0   0   1   0

QB 3 3 0000 0000

QB 4
QB 5

QB 2 4
5

1111 1000
0000 0111

Output of two bytes beginning from QB4 / QB2 to a module that is
defined as a byte module with the data count 2
(no differentiation between the two memory formats as the data are
of byte type):
D7 D6 D5 D4 D3 D2 D1 D0  D7 D6 D5 D4 D3 D2 D1 D0
  1    1    1    1   1   0   0   0      0    0    0   0    0   1   1   1

QW 6 QW 3 6
7

1111 1111
0100 0100

Output of QW6 / QW3 in the data format lower/higher value byte:
D15 D14 D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 D0
   0     1     0      0      0     1     0    0    0   1    1   1    1   1    1   1

Output of QW6 / QW3 in the data format higher/lower value byte:
 D15 D14 D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 D0
    1     1     1     1      1      1     1    1    0   1    0    0    0   1    0   0
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The following table is meant to clarify the method of addressing:

Byte addressing Word addressing

Byte 0 IB 0 IB 0

Byte 1 IB 1

IW 0 Word 0

-

IW 0

Byte 2 IB 2 IB 1

Byte3 IB 3

IW 2 Word 1

-

IW 1

Byte 4 IB 4 IB 2

Byte 5 IB 5

IW 4 Word 2

-

IW 2

Fig. 7-16: Image of the method of addressing for input

Byte addressing Word addressing

Byte 0 QB 0 QB 0

Byte 1 QB 1

QW 0 Word 0

-

QW 0

Byte 2 QB 2 QB 1

Byte3 QB 3

QW 2 Word 1

-

QW 1

Byte 4 QB 4 QB 2

Byte 5 QB 5

QW 4 Word 2

-

QW 2

Fig. 7-17: Image of the method of addressing for output

Master Configuration
The master configuration is described further above in chapter Master
Configuration , page 6-3.
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 Group Membership
After the master has been assigned, the slaves can be assigned to up to
eight different groups. These groups can then be assigned here. Choose
the Settings > Group membership menu. Choose the group that is to
support the DP Freeze and DP Sync commands.

pb_5_12d.bmp

Fig. 7-18: Settings > Group membership (1)

In the Group Membership the slaves can be assigned to the groups with
the desired characteristics. The table shows all configured slave devices
from the main editor window. Here it can be selected to which eight
possible groups the slave is to be assigned.

The selected group membership is transferred to the slaves during their
start-up sequence. The group membership acts as a filter for the Sync
and Freeze global commands. These are output as broadcast telegrams
in order to synchronize the input and output data of several slaves. Only
those slaves in whose group these commands have been released react
on it.

pb_5_13d.bmp

Fig. 7-19: Settings > Group membership (2)
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7.4 DP Slave

Slave Settings
The DP Slave settings contain parameters that define the behavior of the
device at its user interface, which does not belong to the DP configu-
ration. This menu point is applicable only to Hilscher devices. These
settings are transferred with the download of the DP configuration to the
device.

In order to open the DP Slave settings menu, first choose the slave and
then open the window in the Settings > DP Slave Settings menu.

pb_5_14d.bmp

Fig. 7-21: DP Slave settings

• Handshake of the process data

These various functions select the handshake of the process data of the
slave. The selection of the function is important for the correct data
exchange between the application and the device.

• Configuration mode

If the slave device is to use the parameters of the configuration that is
downloaded from SyCon then the Configuration by SYstem
CONfigurator mode must be selected for the Configuration mode. If the
DP configuration is written online from an application into the Dual-Port
Memory, then the Configuration by Application mode must be selected.



7-16 Settings SyConPB

           DOK-CONTRL-SYCON****-DP-AW02-EN-P

• User program monitoring

The monitoring time determines how long the device will wait for an
application triggering until it resets all outputs to zero. This must be
activated from the application.

• Start-up behavior after system initialization

When Automatic release of the communication by the device has
been chosen, then the slave is ready to communicate with the master.
When Controlled release of the communication by the application
program has been chosen, then the user must release the
communication by means of a defined release procedure.

• Configuration data

For Standard, the configuration of the slave is compared with that from
CHK_CFG_TELEGRAM from the master.

For Forced by CHK_CFG_TELEGRAM, the configuration of the slave is
transferred from the master with the CHK_CFG_TELEGRAM to the slave.

• DPV1 Parameter

Class 1 Buffer length: This setting defines the size of the buffer for
DPV1 class 1 services in the DP Slave. The length determines the
maximum data count that can be transferred in a DPV1 class 1 telegram.
Of the buffer size set here, 4 bytes are reserved for the transfer of the
DPV1 administration data and these are not available for the transfer of
user data.

Valid values for the length of the class 1 buffer are in the range of 4 ..
244. Alterations of the size of the buffer can only be undertaken after, in
the slave configuration dialog, the DPV1 services for the slave have been
activated.

Class 2 Buffer length: The length of the DPV1 class 2 buffer that is to be
established must be defined in this field. Analog to the treatment of the
class 1 buffer, here, too, 4 bytes of the given buffer length are reserved
for the transfer of the DPV1 administration data. The maximum
transferable user data count is reduced by these 4 bytes. Values in the
range 48 .. 244 can be defined for the DPV1 class 2 buffer length. If the
value 0 is entered, then the DP Slave lays down no DPV1 class 2 buffer.
In this case the DPV1 class 2 services of the slave are not available.

Note: Please note that the settings of the class 1 and class 2 buffer
lengths influence the usable data width in the cyclical I/O
region. This limitation is caused by the restricted memory
space in the PROFIBUS ASIC (SPC3) of the device.
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The purpose of the examples in the following table is to provide the
possibility of estimating the usable buffer length and I/O data width.

Example Cyclic I/O data DPV1 class 1 buffer DPV1 class 2 buffer

Maximum I/O data 368 60 0

Maximum DPV1 class 1 buffer 304 244 0

Maximum DPV1 class 2 buffer 296 0 244

Maximum DPV1 class 1 buffer and
maximum DPV1 class 2 buffer

200 244 244

128 bytes for DPV1 class 1 buffer 344 128 0

128 bytes for DPV1 class 2 buffer 328 0 128

128 bytes for DPV1 class 1 buffer and
128 bytes for DPV1 class 2 buffer

280 128 128

Fig. 7-22: Buffer length for DPV1

In the case that the given lengths for buffer and I/O data exceeds the
memory space available, the DP Slave will report an error after the
configuration download. This error message can be seen in the extended
device diagnosis of the slave in the ’SPC3’ section under ‘LastError’. If the
error code 75 is entered there, then more memory has been requested in
the PROFIBUS ASIC than is available. Therefore, the DPV1 buffer length
or I/O data width should be reduced and the configuration download
should then be carried out again.

Slave Configuration
The slave configuration is described further above in chapter Slave
Configuration , page 6-6.
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Parameter Data
The parameter data can be edited in the Settings > Parameter data
menu.

If default parameters are configured in the GSD file of the slave, then
these are automatically inserted when the menu is called up for the first
time.

Some of the DP Slave devices require further parameter data, for
instance, in order to change a measuring limit or a value range. This type
of data  is slave-specific and their functionality cannot be described
further here.

The meanings of the parameters are determined by the device
manufacturer. The explanations can be taken from the manufacturer’s
manual.

The window below gives an example of parameter data of a slave:

pb_5_15d.bmp

Fig. 7-23: Parameter data (hexadecimal depiction)

A modular PROFIBUS DP Slave station could require parameter data for
one or more modules and for the slave station itself (main station). There
are three possibilities:

• Parameter data: all the parameters of a slave station

• Common: parameter data of the main station

• Module: parameter data of a module

After the choice of the text button, there appears the following window
with the text parameter data. These parameters are for the main station.



SyConPB Settings 7-19

DOK-CONTRL-SYCON****-DP-AW02-EN-P           

pb_5_16d.bmp

Fig. 7-24: Parameter data (text depiction)

It is possible to return to the hex depiction by pressing the hex button.

It is possible to edit the value by means of a double click on a row of
parameter data.

pb_5_17d.bmp

Fig. 7-25: Parameter data (individual depiction)

or to change the description via the text setting.

When several modules in the slave configuration have been selected,
then it is also possible to change the module parameters by means of a
double click on its associated line.
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If more than one module is being configured, then a window appears in
which a module must be selected.

pb_5_18d.bmp

Fig. 7-26: Parameter data
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7.5 DPV1 Parameter

DPV1 serves for acyclic data exchange and offers read, write and alarm
processing functions.

The following information refer to Hilscher devices.

pb_5_19d.bmp

Fig. 7-28: DPV1 settings

Additional slave functions:

• Abort of cyclic connection

When this point is chosen, the master does not remain in the
DATA_EXCHANGE condition for the affected slave if the slave has been
recognized as incorrect, but breaks off the connection to the slave. The
slave will in any case delete the outputs even when the connection in the
direction of the slave is still functionally correct but the return for the
answer telegram to the master is interrupted.

• Fail Safe Support

This mode indicates to the master that the affected slave is working in a
so-called Fail_Safe mode. If the mode is activated, the master will send in
the condition CLEAR instead of the zero output data, output data of length
= 0. On the basis of this process, the slave immediately recognizes that
the master is in the CLEAR condition even if a previous CLEAR command
was destroyed on the bus.

• Ignore Auto Clear

The global auto clear function is carried out or ignored when the
connection to the slave is interrupted.
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DPV1

• Maximum Channel Data Length

Defines the maximum length of the DPV1 telegrams. The slave will then
adapt its buffer size for the respective data count.

• Diagnostic Update Delay

Some slave devices of the newer models require more time for the
consistency testing for the processing of the SET_PRM parameterizing
telegrams. Often, therefore, a simple diagnosis cycle is insufficient until
the participant can inform the master of the release for the
DATA_EXHCHANGE. With the diagnostic delay, the number of diagnosis
cycles that is the maximum that the master expects in order to obtain this
release is increased before it reports an error.

• Maximum Alarm PDU Length

Determines the maximum length of the DPV1 alarm telegrams.

• Maximum Active Alarms

Determines the maximum quantity of active alarms: one alarm of each
type or 2, 4, 8, 12, 16, 24 or 32 alarms in total.

Slave functions

• Extra Service Access Point for Alarm Acknowledgement

Determines whether the DPV1 acknowledges an alarm via SAP 51 or 50
at the DPV1 Slave.

• Configuration Data Convention

Determines whether the configuration data are interpreted according to
EN 50170 or DPV1.

Enabled alarms

Activates or deactivates the alarms Pull Plug Alarm (module referenced),
Process Alarm, Diagnostic Alarm, Manufacturer Alarm, Status Alarm
and Update Alarm.
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7.6 Project Information

If the user creates his own project, then the project information can be
written into the Settings > Project Information menu. Anybody can then
read this entry when this menu is called up.

pb_5_21d.bmp

Fig. 7-30: Settings > Project information

7.7 Search Path

When the Settings > GSD Search Path menu is selected, then the
search path for GSD files is displayed.

pb_5_22d.bmp

Fig. 7-31: Settings > Search path
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7.8 Language

Choose the Settings > Language menu and the following window opens:

pb_5_23d.bmp

Fig. 7-32: Settings > Language

Here one is in a position of setting the language of the system
configurator. Select the desired language and confirm the entry with the
OK button.

A message appears that the system configurator must be started again in
order to activate the selected language. Please carry this out.

After restarting the system configurator, the language will have changed
to the one selected.

Note: Up to now not all languages are available for all fieldbusses!
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7.9 Start Options

After activating the Settings > Start Options menu point in the network
mode, the following dialog will appear.

Here it is possible to set the various starting options or modes. Some are
of importance only for the OPC server operation.

The important ones are given below.

pb_5_24d.bmp

Fig. 7-33: Settings > Start options

• Start SyCon next time with last configuration

When this is marked the last saved configuration in the SyCon is
automatically loaded when the SyCon is started again.

• Logic Network View visible

When this is marked, there is the possibility of diverting to the network
mode without having to install the SyCon with OPC. It is also possible to
use the watch list from the network mode.
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8 Online Functions
In this chapter, all the functions that directly influence Hilscher PROFIBUS
devices, e.g. CIF 30-PB, PKV 20-DPM, are presented.

Please note that this also permits an interruption of the running
communication or that inlets and outlets can be switched On or Off.

8.1 Online to the CIF

Downloading the Configuration
First, the desired device must be chosen for downloading by a left mouse
click on the symbol of the device.

In order to release the configuration and network access, a transfer
(Download) to the CIF/COM/PKV devices must be carried out on the
Online > Download menu. A warning will appear that the communication
on the PROFIBUS will be interrupted. This warning must be confirmed.

pb_6_01d.bmp

Fig. 8-1: Security query before download

pb_6_02d.bmp

Fig. 8-2: Online > Download

Before the download is carried out, the configuration is tested by the
configurator. The most common cause of error is overlapping of
addresses in the process data image. This can be checked by calling up
the address table with the View > Address Table menu point.

If the issue of addresses in the process data image is carried out
automatically, then the Auto addressing button in the Master
Configuration window must be activated.
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The configuration is transferred into the selected device and is stored
there in FLASH memory in a zero voltage manner, so that the
configuration is available, when the voltage supply is switched off and on
again.

After the download, the device carries out an internal restart and begins
with the communication, if in DP Master Settings the Automatic
Release of Communication by the Device menu point has been set.

Firmware Download
If a firmware download is to be carried out, proceed as follows: first the
desired device for firmware downloading must be chosen by selecting the
symbol of the device with a left mouse click. Then, call up the Online >
Firmware Download menu. Select the new firmware and retrieve it with
Download into the device. The firmware is now retrieved.

pb_6_03d.bmp

Fig. 8-3: Online > Firmware Download

Firmware / Reset
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then the Online > Firmware / Reset menu must
be called up and the name and the version of the Firmware are displayed.

pb_6_04d.bmp

Fig. 8-4: Online > Firmware / Reset

The device is reset with the Reset button.
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Device Info
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Device Info menu in
order to obtain further information on the selected device.

The manufacturer date, the device number and the serial number of the
device is retrieved and shown.

pb_6_05d.bmp

Fig. 8-5: Online > Device Info

8.2 Start/Stop Communication

The communication between PROFIBUS DP Master and PROFIBUS DP
Slave can be manually started or stopped.

First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Communication start or
Online > Communication stop menu.

8.3 Diagnostic Functions

Live List
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Live List menu and
obtain an overview over all active devices at the PROFIBUS network.
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pb_6_07d.bmp

Fig. 8-6: Online > Live List

A green number shows a master and a blue number a slave, whereby the
number indicates the station address. The meaning of the other colors is
given in the list above the table.

A click on a colored number brings up its device type, and device status
of the station.

pb_6_08d.bmp

Fig. 8-7: Device type and device status of a master

pb_6_09d.bmp

Fig. 8-8: Device type and device status of a slave

The display is not automatically updated as this function loads the
PROFIBUS network. However, the Live List can be renewed with the
Update button.
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Debug Mode
First the master device must be chosen with a left mouse click on the
symbol of the master device. Then select the Online > Start Debug
Mode menu. The system configurator cyclically interrogates the status of
the network communication on the CIF, COM, PKV or KPO and the
individual condition of the devices.

To end the debug mode select the menu Online > Stop Debug Mode.

Note: The debug mode is only for PROFIBUS DP communication.

The Debug Window

When started the debug session the configuration window changes into
the debug window. The devices and the line between them are displayed
in green or red color depending on the established network
communication.

pb_6_10d.bmp

Fig. 8-9: The Debug Window

If a diagnostic information is available for a specific device, next to the
device icon the text Diag appears in red. To get further device-specific
diagnostic information, double-click on the device itself or set the focus to
the device and select Online > Device Diagnostic.
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Device Diagnostic
After the debugger was started, SyCon requests the status of all devices
from the master. If there is an error on a device the bus line to this slave
is drawn in red color otherwise it is green. SyCon also displays the letters
Diag, if the device signals a diagnostic information. This information is
displayed closer if you click with the mouse onto the corresponding device
in debug mode.

To activate the debug mode, select the menu Online > Start Debug
Mode. The menu Online > Device Diagnostic activates the PROFIBUS
device diagnostic. To end the Debug Mode, select the menu Online >
Stop Debug Mode.

pb_6_11d.bmp

Fig. 8-10: Online > Device Diagnostic (PROFIBUS DP standard diagnostic)

The Device Diagnostic and its meaning.

• Master_Lock

The slave has already been parameterized by another master and is
locked in its access. Check, if another master is present on the network
and delete its assignment to this slave station or remove the other
assigned master from the network to get the communication with this
slave run.

• Parameter_Fault

This bit is set by the slave automatically, when the parameters send by
the master are containing wrong or insufficient data. On every received
parameter telegram the slave executes a check routine on the whole
parameter telegram. If the slave detects a faulty parameter value or illegal
data during its check, it will report the ’parameterization error’. During the
check routine the slave compares its ident_number with the one sent by
the master. So, if the slave reports this error, first compare the real
ident_number shown in the slave  diagnostic field in debugger mode with
the one read out of the GSD file. For this, take the menu ’View/Device
table’. Another problem can be, that you have entered with SyCon more
parameter data than the slave can support. If this is the case, reduce the
number of parameter data.
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• Invalid_Slave_Response

This bit is set by the master, when the master receives an invalid answer
from the slave. So the physical contact to the slave works principally, but
the logical doesn’t or was interrupted. This can for example happen, if a
PROFIBUS FMS Slave is connected to the DP Master. So the slave does
not understand the DP telegrams and rejects these. It’s handled as
’Invalid_Slave_Response’.

• Not_Supported

This bit is set by the slave, when a function should be performed which is
not supported. Newer releases of slave stations normally support the
Sync and Freeze-Mode for I/O data. This is fixed in the GSD file and read
out by SyCon and overgiven to the slave in the parameter telegram. If
’Not_Supported’ is reported the GSD file declares at least one of these
commands as supported, but the slave does not. So ask the
manufacturer of the slave device for other GSD file or ask, if the slave
reports ’Not_Supported’ on other wrong parameter data.

• Extended_Diag

This bit is set by the slave, if optional extended diagnostic data are a
containment of the slave diagnostic field. Extended diagnostic data is
normally used by a slave station, if module specific diagnostic information
like for example exceeded analog values or low power should be reported
to the master. Click on the button ’Extended Diagnostic’ to get a Hex-
dump of the reported values.

• Configuration_Fault

During the PROFIBUS DP startup procedure the slave compares its
internal I/O configuration with the configured one in the master. If the
slave detects differences it will report the ’Cfg_Fault’ error. That means
that the master has an other I/O module constellation than the slave. So,
first compare visually all configured I/O modules in the configuration data
of SyCon for this slave with its real physical constellation. Note that the
order of the module is important and has to be also compared. Some
slaves need virtual I/O modules to be configured first or empty slot
modules to get an even number of modules to run. This slave specific I/O
module behavior can normally be read out in the slave documentation.
Last help to get the slave module constellation is to read out its
constellation by a PROFIBUS DP command Compare Configuration. So
click on this button in the diagnostic field and you will get a Hex-Dump of
the real slave configuration data and the configured one (Real
Configuration and SyCon Configuration). Note that the DP
configuration data is coded in bit defined byte arrays to hold the I/O
information very compressed.

Note, that the DP configuration is coded in a very compact form. The
code for the modules is shown in the Slave configuration.

• Station_Not_Ready

When or at which event the slave sets this bit is not defined in the norm
specification. Its meaning ’Not_Ready’ can be seen as not ready to do the
I/O data exchange. This can have several slave-specific reasons. Usually,
this fault occurs in combination with an other fault.

• Station_Non_Existent

This bit is set by the master automatically, if this slave is not responding
on the bus. If this error occurs, compare the configured station address
with the physical one of the slave. Then check, if the slave module
supports the configured baud rate. Some old modules support a baud
rate up to 1.5 mbaud only. Other modules must be jumpered to DP Norm
behavior first, to be operative with a DP Norm master. Then check your
bus cable. Only the TX/RX-pins 3<->3 and 8<->8 must be connected to
get the contact between two PROFIBUS components.
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• Slave_Deactivated

This bit is automatically set by the master, if the slave in its parameter set
is marked as inactive, so that it is taken out from the cyclic I/O
processing.

• Sync_Mode

This bit is set by the slave, when it has received the sync-control
command.

• Freeze_Mode

This bit is set by the slave, when is has received the freeze-control
command.

• Watchdog_ON

This bit is set by the DP Slave, when its watchdog control is active to
supervise its corresponding master connection.

• Slave Device

This bit is always set by the slave device.

• Static_Diag

The slave sets this bit to indicate the master system to be not operative
for I/O because of a general error. In a case of a set static diagnostic bit
the master has to collect diagnostic information as long as this bit is
active. On which events or at what time this bit can be set by a slave
device, is not defined in the norm description and can not be mentioned
here.

• Parameter_Req_used

The slave sets this bit to force the master system to do a new
parameterization. This bit is set as long as new parameterization must be
performed.

• Ext_Diag_Overflow

This bit is set, if there is more extended diagnostic information to report to
the master than can be given to the master in one DP diagnostic
telegram. The DP Slave sets this bit for example, if there is more
diagnostic channel information than the slave can hold down in its
diagnostic buffer.
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Extended Device Diagnostic

pb_6_12d.bmp

Fig. 8-11: Device diagnostic (PROFIBUS DP extended diagnostic)

In the extended device diagnostic window, the data of the diagnostic
telegram are shown as a Hex-dump. Here, the first 6 bytes are the
standard diagnostic bytes. The extended device diagnostic starts at the
7th byte.

The box in the middle of the window shows details and the box on the top
the diagnostic report in clear text, insofar as these are given in the GSD
file.
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Global State Field
First chose the desired device with a left mouse click on the symbol of the
device. Then select the Online > Global State Field menu. A display
window opens, in which the cyclic states on the bus condition and the
connected devices are shown.

The first row shows the main state of the master. This can have the
condition  OPERATE or STOP.

The next row shows individual bus errors. A current error is shown in a
red field. The meanings of the individual abbreviations are shown below.

pb_6_13d.bmp

Fig. 8-12: Online > Global state field

Collective status bits

• TOUT: TIMEOUT-ERROR, the device has detected a
overstepped timeout supervision time, because of rejected PROFIBUS
telegrams. It’s an indication for bus short circuits, while the master
interrupts the communication. The number of detected timeouts are
fixed in the statistic bus information variable. The bit will be set, when
the first timeout was detected and will not be deleted any more.

• NRDY: HOST-NOT-READY-NOTIFICATION indicates, if the host
program has set its state to operative or not. If this bit is set, the host
program is not ready to communicate.
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• EVE: EVENT-ERROR, the device has detected bus short
circuits. The number of detected events are fixed in the statistic bus
information variable. The bit will be set, when the first event was
detected and will not be deleted any more.

• FAT: FATAL-ERROR because of heavy bus error, no further
bus communication is possible.

• NEXC: NON-EXCHANGE-ERROR, at least one slave has not
reached the data exchange state and there’s no process data
exchange with the DP Master.

• ACLR: AUTO-CLEAR-ERROR, device stopped the
communication to all slaves and reached the auto-clear end state.

• CTRL: CONTROL-ERROR, parameterization error.

Further contents are given:

Collective online error location and corresponding error indicates the
station address and the error text.

Statistic bus information displays the number of the detected bus short
circuits and the number of rejected telegrams.

Device specific status bits:

Parameterized Devices, Activated Devices and Devices with
Diagnostic are shown, if you click at that button. The activated addresses
are colored numbers. You can see the diagnostic message by double-
clicking at a highlighted station address of a device.

This application updates online the status in the global state field.

Extended Device Diagnostic
The extended device diagnostic assists in finding bus and configuration
errors when the SyCon menu functions are of no further help.

First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Extended Device
Diagnostic menu.

This menu opens a list of diagnostic structures. These contain online
counters, states and parameters:

pb_6_14d.bmp

Fig. 8-13: Extended Task State as and example for the PROFIBUS DP/FMS
combimaster
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For the PROFIBUS DP

• USR_INTF (User-Interface): DP administration

• FDL_TASK: PROFIBUS Transmission

Task Task state Page PB DPM

PLC_TASK Common Variables 8-14 X X

Task State 8-15 X X

Running States 8-16 X X

Global State Field 8-10 X X

Communication Error 8-17 X X

Parameter Set List 8-18 X X

Last Download Param. 8-19 X X

Disconnect Report 8-20 X X

Diagnostic Report 8-21 X X

USR_INTF

DPV1 Data 8-22 X X

Task State 8-23 X X

Act. Bus parameter 8-24 X X

DDLM Requests (Cl. 1) 8-25 X X

DDLM Requests (Cl. 2) 8-26 X X

FDL Requests 8-27 X X

FMA Requests 8-28 X X

DP: Retry for Slaves 8-29 X X

DP: Activated Slave 8-30 X X

FDL_TASK

DPV1 Requests 8-31 X X

VFD Status 8-32 X

FDL Services 8-33 X

Error Counter 8-34 X

Client Parallel Services 8-35 X

ALI_TASK

Server Parallel Services 8-36 X

Status ComReference 8-37

Timer ComReference 8-38

Fig. 8-14: PROFIBUS DP Master Task State
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For the PROFIBUS DP Slave

• PLC_TASK

• SPC3CTRL (SPC3 Control)

Task Task state Page DPS

PLC_TASK Variables 8-39 X

SPC3 8-40 X

Slave Config 8-41 X

Master Config 8-42 X

Param Data 8-43 X

SPC3 DPM 8-44 X

DPV1 Class 1 8-45 X

DPV1 Class 2 8-46 X

SPC3CTRL

Code Diagnostic 8-47 X

Fig. 8-15: PROFIBUS DP Slave Task State
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On the following pages the task state structure of PROFIBUS DP is
described.

pb_6_15d.bmp

Fig. 8-16: PLC_TASK Common Variables

Variable Meaning

Version Compiled Hardware

Task State Task State

Handshake Counter Counter for the performed process data hand shakes

Handshake Mode This value represents the actual handshake mode between application and
CIF.

0 = Bus synchronous, device-controlled

1 = Buffered, device-controlled

2 = Uncontrolled

3 = Buffered, host-controlled

4 = Bus synchronous, host-controlled
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Fig. 8-17: USR_INTF Task State

Variable Meaning

Scheduler State Status value of the scheduler

Announced Modules Number of configured slaves

Wrong Parameters Number of slaves with faulty data sets

Activated Modules Number of activated slaves

Activated Bus Parameters 0 = Bus parameter active, 255 = Bus parameter inactive

Active Data Exchange Current active Data_Exchange-Service

Inactive Data Exchange Number of Stations with that process data exchange is not possible

Active Queue Number of stored commands

Data Control Time Counter of Data_Contol_Time

Min. Interval Time Counter of min.Slave_Intervals

Width of used RAM

Faulty Station Address Station address of the faulty station

Timeout Counter Supervision counter that is activated, when a short-circuit was detected on the
bus
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Fig. 8-18: USR_INTF Running States

Variable Meaning

Slave x (x=0 .. 125) Slave handler-state for Station address x

USR_INTF Global State Field

See chapter Global State Field on page 8-10.
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Fig. 8-19: USR_INTF Communication Error

Variable Meaning

Slave x (x=0 .. 125) Error number to the slave
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Fig. 8-20: USR_INTF Parameter Set List

Variable Meaning

Slave x (x=0 .. 125) 0 = no or no valid parameter data set

1 = valid parameter data set
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Fig. 8-21: USR_INTF Last Download Param

Variable Meaning

Byte 0 to 119 Last parameter data set
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Fig. 8-22: USR_INTF Disconnect Report

Variable Meaning

Slave x (x=0 .. 125) Counter for disconnection for slave x (x = 0 to 125)

The status table shows the number of communication break downs
(disconnections) resulted by a bus communication error for each slave
station. The counter is only incremented, when the master has already
communicated in the ’Data Exchange All’ mode with all slaves. A fatal
error is, when the maximum number of retries is reached (given by the
max_retry_limit of the DP Norm). See bus parameter max_retry_limit.
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Fig. 8-23: USR_INTF Diagnostic Report

Variable Meaning

Slave x (x=0 .. 125) Counter for diagnostic reports for slave x (x = 0 .. 125)

The status table shows the number of diagnostic reports for each slave
station that has reported to the master. For each received report the
data_exchange state to this slave was left for one DP cycle to read out
the diagnostic information.
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Fig. 8-24: USR_INTF DPV1 Data

Variable Meaning

Read Req Counter for Read Requests

Read Con Pos Counter for Read Confirmations Positive

Read Con Neg Counter for Read Confirmations Negative

Write Req Counter for Write Requests

Write Con Pos Counter for Write Confirmations Positive

Write Con Neg Counter for Write Confirmations Negative

Alarm Req Counter for Alarm Requests

Alarm Con Pos Counter for Alarm Confirmations Positive

Alarm Con Neg Counter for Alarm Confirmations Negative

FDL Data Reply Req Counter for FDL Data Reply Requests

FDL Data Reply Con Pos Counter for FDL Data Reply Confirmations Positive

FDL Data Reply Con Neg Counter for FDL Data Reply Confirmations Negative

Change Diag Ind. Counter for Change Diag Indication

Alarm Stop Ind. Counter for Alarm Stop Indication

Stop Line Counter for Stop Line

Alarm Not Enable Counter for Alarm Stop Enable

Status Counter for Status
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Fig. 8-25: FDL_TASK Task State

Variable Meaning

Task State Task state number

Last FDL error state Error state

Last FDL init. Error Initialization error

Last FDL runtime error Runtime error

ASPC2 bus short circuit Counter for occurred bus SyCon error reports or bus short circuits of the
ASPC2

ASPC2 bus error Counter for occurred bus error reports of the ASPC2

Free application blocks Free application blocks of the software

Free SAP blocks Free SAP blocks of the software

Free CLASS2 blocks Free class 2 blocks of the software
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Fig. 8-26: FDL_TASK Act. Bus parameter

Display of the bus parameters

Variable Meaning

Highest station address HSA Highest Station address

Bus address of this master station TS (This station) own bus address

Transmission rate Transmission rate

0 = 9600; 1 = 19200; 2 = 93,75; 3 = 187,5; 4 = 500k; 7 = 1.5M; 8 = 3M; 9 = 6M;
10 = 12M

Maximum request retry in error case Number of retries for bus errors

Slot time TSL Slot Time

Transmitter fall time TQUI Transmitter Fall Time

Setup time TSET Setup Time

Smallest station delay MIN TSDR minimum station delay

Largest station delay MAX TSDR maximum station delay

Target rotation time TTR Target Rotation Time

GAP update factor G GAP Update Factor
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Fig. 8-27: FDL_TASK DDLM Requests Class 1

Variable Meaning

Set bus parameters Counter for ’Set-Bus-Par’ Request

Set Slave address list Counter for ’Set-Slave-List’ Request

Slave diagnostic requests Counter for ’Slave-Diag’ Request

Set parameter request Counter for ’Set-Prm’ Request

Check configuration request Counter for ’Check-Cfg’ Request

Global control request Counter for ’Global-Control’ Request

Data exchange requests Counter for ’Data-Exchange’ Request

Data exchange conf pos Counter for ’Data-Exchange’ Confirmation positive

Data exchange conf neg Counter for ’Data-Exchange’ Confirmation negative

Data exchange all requests Counter for ’Data-Exchange-All’ Request

Data exchange all conf pos Counter for positive Confirmation of ’Data-Exchange-All’

Data exchange all conf neg Counter for negative Confirmation of ’Data-Exchange-All’

Services that are activated on the bus according to the PROFIBUS
specification are counted in this window. Basically, on an error-free
network only the ’data-exchange-all’ counter should count up. The
services ’set-slave-list’, ’set-prm’, ’chk-cfg’, ’data-exchange’ should count
1 for each configured slave device on an error free network start up. If the
counter for these services count continuously then this indicates a bus
error. If the service ’slavediag’ is e.g. sporadically increased, the bus
cable could be defective or there’s no cable resistor. Another possibility
could be a conscious error report of a slave module that activates the
service in the master.
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Fig. 8-28: FDL_TASK DDLM Requests Class 2

Variable Meaning

Service/Function Counter for this service/function



SyConPB Online Functions 8-27

DOK-CONTRL-SYCON****-DP-AW02-EN-P           

pb_6_28d.bmp

Fig. 8-29: FDL_TASK FDL Requests

Variable Meaning

SDA request Counter for ’SDA’ Request

SDA confirmation pos Counter for ’SDA’ Confirmation, positive

SDA confirmation neg Counter for ’SDA’ Confirmation, negative

SDA indication Counter for ’SDA’ Indication

SDN request Counter for ’SDN’ Request

SDN confirmation pos Counter for ’SDN’ Confirmation, positive

SDN confirmation neg Counter for ’SDN’ Confirmation, negative

SDN indication Counter for ’SDN’ Indication

SRD request Counter for ’SRD’ Request

SRD confirmation pos Counter for ’SRD’ Confirmation, positive

SRD confirmation neg Counter for ’SRD’ Confirmation, negative

SRD indication Counter for ’SRD’ Indication

SRD update request Counter for ’SRD’ Update Request

SRD update con pos Counter for ’SRD’ Update Confirmation, positive

SRD update con neg Counter for ’SRD’ Update Confirmation, negative

FDL Services that are activated on the bus according to the PROFIBUS
specification are counted in this window. The request (send), its
confirmation (positive or negative) and the indication (received) are
counted.

Not all services/functions are supported by the firmware.
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Fig. 8-30: FDL_TASK FMA Requests

Variable Meaning

SAP act. Request Counter for ’SAP Activate’ Request

SAP act. Confirmation pos Counter for ’SAP Activate’ Confirmation, positive

SAP act. Confirmation neg Counter for ’SAP Activate’ Confirmation, negative

RSAP act. Request Counter for ’RSAP Activate’ Request

RSAP act. Confirmation pos Counter for ’RSAP Activate’ Confirmation, positive

RSAP act. Confirmation neg Counter for ’RSAP Activate’ Confirmation, negative

SAP deact. Request Counter for ’SAP Deactivate’ Request

SAP deact. Confirmation pos Counter for ’SAP Deactivate’ Confirmation, positive

SAP deact. Confirmation neg Counter for ’SAP Deactivate’ Confirmation, negative

LiveList request Counter for ’LiveList’ Request

LiveList confirmation pos Counter for ’LiveList’ Confirmation, positive

LiveList confirmation neg Counter for ’LiveList’ Confirmation, negative

FMA Services that are activated on the bus according to the PROFIBUS
specification are counted in this window. The request (send) and its
confirmation (positive or negative) are counted.

Not all services/functions are supported by the firmware.
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Fig. 8-31: FDL_TASK DP: Retry for Slave

Variable Meaning

Slave x (x=0 .. 125) Retries for slave x (x=0 .. 125)

If a telegram for a slave had to be send twice or up to 7 times because of
a bus error, this is counted for each slave in this window. The single count
of retries per telegram can’t be read out here.
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Fig. 8-32: FDL_TASK DP: Activated Slave

Variable Meaning

Slave x (x=0 .. 125) Inactive (=0) or active (=1) Slave x (x=0 .. 125)
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Fig. 8-33: FDL_TASK DPV1 Requests

Variable Meaning

Read request Counter for DPV1 Read request

Read confirmation pos Counter for DPV1 Read confirmation positive

Read confirmation neg Counter for DPV1 Read confirmation negative

Write request Counter for DPV1 Write request

Write confirmation pos Counter for DPV1 Write confirmation positive

Write confirmation neg Counter for DPV1 Write confirmation negative
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Fig. 8-34: ALI_TASK VFD Status

Variable Meaning

Logical

Physical

Detail Len

Detail[0]

Detail[1]

Detail[2]
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Fig. 8-35: ALI_TASK FDL Services

Variable Meaning

FdlSendSda Counter for FDL Send SDA

FdlSendSdn Counter for FDL Send SDN

FdlReceiveSda Counter for FDL Receive SDA

FdlReceiveSdn Counter for FDL Receive SDN

FdlAcknowledgePos Counter for FDL Acknowledge positive

FdlAcknowledgeNeg Counter for FDL Acknowledge negative

FdlRequest Counter for FDL Request

FdlConfirmationPos Counter for FDL Confirmation positive

FdlConfirmationNeg Counter for FDL Confirmation negative

FdlIndication Counter for FDL Indication

FdlResponsePos Counter for FDL Response positive

FdlResponseNeg Counter for FDL Response negative

FdlAbort Counter for FDL Abort
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Fig. 8-36: ALI_TASK Error Counter

Variable Meaning

User, FMS, FDL Counter for errors
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Fig. 8-37: ALI_TASK Client Parallel Services

Variable Meaning

ComReference x (x = 1 ..32) Counter for active client services
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Fig. 8-38: ALI_TASK Server Parallel Services

Variable Meaning

ComReference x (x = 1 ..32) Counter for active server services
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Fig. 8-39: ALI_TASK Status ComReference

Variable Meaning

Device in Ring Device in the token ring

ComReference x (x = 1 ..32) State of the communication reference

0 = connection closed

1 = connection is established at the moment

2 = connection established
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Fig. 8-40: ALI_TASK Timer ComReference

Variable Meaning

Status CR x (x = 1 ..32) State of the communication reference

0 = connection closed

1 = connection is established at the moment

2 = connection established

Services

Initial value
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On the following pages the task state structures for PROFIBUS DP Slave
are described.

pb_6_42d.bmp

Fig. 8-41: PLC_TASK Variables

The variables of the PLC task are not longer supported in newer firmware
because of  performance reasons.
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Fig. 8-42: SPC3CTRL SPC3

Variable Meaning

Baud Rate Baud rate

Bus Address Bus address

Ident Number Ident number

Task State Task state

Input Length Length of input bytes for cyclic transfer

Output Length Length of output bytes for cyclic transfer

Error Cnt Error counter

Last Error Error code of the last error

IRQ Select Number of the SPC3 interrupt line

IRQ Polarit. Polarity of the SPC3 interrupt line

Device Manuf. Device manufacturer

Device Type Device type

Device Model Device model

IRQ Bits Type of the last SPC3 interrupts

IRQ Cnt Counter for SPC3 interrupt requests

Addr Switch Type of the address switch

DevTabEntry Internal usage

Module Count Number of the configured input/output modules on the PROFIBUS

I/O Field Len Length of the input/output data buffer in the SPC3

Kbyte Field Len Length of the configuration data buffer in the SPC3

Param Field Len Length of the parameter data buffer in the SPC3

Diag Field Len Length of the diagnostic data buffer in the SPC3

Param User Internal usage

State Param Internal usage
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Fig. 8-43: SPC3CTRL Slave Config

Variable Meaning

Config Length Length of the actual configuration data in the slave

Config Byte 1 Configuration data Byte 1

... ...
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Fig. 8-44: SPC3CTRL Master Config

Variable Meaning

Config Length Length of the configuration data send by the master

Config Byte 1 Configuration data Byte 1

... ...
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pb_6_46d.bmp

Fig. 8-45: SPC3CTRL Param Data

Variable Meaning

Param Length Length of the User-Param-Data send by the master

Param Byte User-Param-Daten-Byte 1

... ...

The standard parameter data bytes are not displayed.
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Fig. 8-46: SPC3CTRL DPM

Display of the internal variables of the SPC3 PROFIBUS ASIC.
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pb_6_48d.bmp

Fig. 8-47: SPC3CTRL DPV1 Class 1

Variable Meaning

Status Requests from User Status reports by the user

Status Messages Sent Status reports sent to the PROFIBUS

Negative Status Confirmations to User Status reports rejected with error by the user

Diagnosis Requests from User Single diagnostic reports by the user

Diagnosis Messages Sent Single diagnostic reports sent to the PROFIBUS

Negative Diag Confirmations to User Single diagnostic reports rejected with error by the user

Alarm Request from User Alarm reports by the user

Alarm Messages Sent Alarm reports sent to the PROFIBUS

Positive Alarm Confirmations to User Alarm reports confirmed by the user

Negative Alarm Confirmations to User Alarm reports rejected by the user

Requests DPV1 class 1 requests from PROFIBUS received

Immediate Negative Confirmations DPV1 class 1 requests rejected with error

R/W Indications to User Read/Write requests forwarded to the user

Positive R/W Responses from User Read/Write requests from the user (positive)

Negative R/W Responses from User Read/Write requests from the user (negative)

Alarm Ack Indications Alarm acknowledgement from PROFIBUS received

Alarm Ack Responses Alarm acknowledgement answered

Alarm Ack Errors Alarm acknowledgement with errors

Erroneous Responses from User DPV1 class 1 answers from the user with error

Unexpected Responses from User Unexpected DPV1 class 1 answers from the user
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Fig. 8-48: SPC3CTRL DPV1 Class 2

Variable Meaning

PDUs Received DPV1 class 2 PDUs from PROFIBUS received

PDUs Provided DPV1 class 2 PDUs given to the PROFIBUS

PDUs Fetched by Master DPV1 class 2 PDUs taken by the master on the PROFIBUS

Initiate Indications to User Initiate indication forwarded to the user

Positive Initiate Responses from User Initiate response of the user (positive)

Negative Initiate Responses from User Initiate response of the user (negative)

R/W/T Indications to User Read/Write/Data transport indication forwarded to the user

Positive R/W/T Responses from User Read/Write/Data transport responses of the user (positive)

Negative R/W/T Responses from User Read/Write/Data transport responses of the user (negative)

Idle Requests Received Idle telegrams received from PROFIBUS

Idle Requests Sent Idle telegrams sent to PROFIBUS

Abort Requests Received Abort request received from PROFIBUS

Abort Requests Sent Abort request sent to PROFIBUS

Abort Requests from User Abort request from user

Abort Indications to User Abort indication forwarded to user

Erroneous Responses from User DPV1 class 2 answers of the user with error

Unexpected Responses from User Unexpected DPV1 class 2 answers of the user

Services Stopped DPV1 class 2 services stopped
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Fig. 8-49: SPC3CTRL Code Diagnostic

Display for state and error reports from the firmware.
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8.4 User Data

I/O Monitor
This is an easy way of viewing and changing the first 32 bytes of the
process data image.

pb_6_52d.bmp

Fig. 8-50: Online > IO Monitor

DEC/HEX converts the display of the input data. The output data are
always in the decimal form.

Enter the output value and then press Update.

Always the first 32 input and output bytes of the process depiction are
shown, also when these bytes have not been occupied by the
configuration.

The display is always in a byte manner.

A more comfortable display is offered by the I/O Watch Monitor that is
described in the next section.

I/O Watch
The I/O Watch Monitor can be used in place of the I/O Monitor and offers
more functionalities.

• Various data formats: Hex, Unsigned Decimal, Signed Decimal, Bit

• The I/O Watch Monitor works symbol oriented

• It is not necessary to know the offset addresses

The I/O Watch Monitor function is supported by PROFIBUS DP Master
from version 1.140 upwards.
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The following list contains the typical steps to use the I/O Watch Monitor.

Preconditions:

• The project/configuration already exists, containing a PROFIBUS DP
Master and the PROFIBUS DP Slave(s) as described in chapter
Configuration Sequence on page 5-1.

• The Configuration has been downloaded into the PROFIBUS DP
Master using Online > Download

• Running bus system

1. Open the existing project using File > Open.

2. Open the Windows drop-down menu and select Window > Logical
Network View to change the window. A window with three sections
opens:

Left Window Center Window Right Window

Project tree structure Tag / Symbol IO Watch

3. Open the tree structure in the left window to reach the I/O module of
the device desired:

Project > Master > Slave > Module > (if existing) Sub module

pb_6_53d.bmp

Fig. 8-51: Logical Network View and I/O Watch

4. Left click on the module desired and the tags (I/Os) will be displayed
in the center window of the Logical Network View.

5. Select with the left mouse button the tag/symbol desired and drag and
drop them in the right window of the Logical Network View.

6. In the right window select the desired tag with the left mouse click to
highlight it then right mouse click to open a menu. Select Start. A new
window called I/O Watch appears.

7. A table shows the Device, Symbolic Name, IEC Address (Offset),
Data type Representation and Value. Select the line with the desired
information. Click on Hex under Representation and select the way
the values are to be displayed. Choices are Hex, Decimal unsigned,
Decimal signed, Bit pattern.

8. Input data are displayed and can’t be changed. Output data can be
entered into the value column.
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Fig. 8-52: I/O Watch Window

In column "Representation" you can choose the data type: Bit Pattern,
Char, Decimal Signed, Decimal Unsigned, Hex.

To close this window use ALT-F4 or click in the upper left corner of the
window select Exit.
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8.5 PROFIBUS Services

Setting the Slave Address
First the desired slave device must be chosen with a left mouse click on
the symbol of the slave. Then set the stations address of a slave at the
PROFIBUS with the Online > Set Slave Address menu.

Enter the new address into the New station address field. If you do not
want to allow further alterations to the station address, mark the No
additional changing  field. If required, enter further parameters in
hexadecimal format into Remote Slave parameter field. Activate the
command with the OK button.

pb_6_59d.bmp

Fig. 8-53: Online > Set Slave address

The setting of the station address is only possible for slaves that support
this service.
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Message Monitor for Testing of DPV1 (at Master)
In the following, the Message Monitor for reading and writing via DPV1 at
the master is described.

The following must be entered in the Message Monitor in order to read
data via DPV1 from a slave:

Message header

Rx = 3 (always) Tx = 255

Ln = (calculated) No = 0 .. 255

A = 0 F = 0

B = 17 E = 0

Telegram  header Meaning for DPV1 Value range

Device Adr Station address of the slave 0 .. 126

Data Area Unused 0

Data Address Slot 0 .. 254

Data Index Index 0 .. 255

Data Count Data Count 1 .. 240

Data Type Data Type 10

Function Read 1

Fig. 8-54: Message Monitor – Example DPV 1 Read

The following must be entered in the Message Monitor in order to write
data via DPV1 to a slave:

Message header

Rx = 3 (always) Tx = 255

Ln = (calculated) No = 0 .. 255

A = 0 F = 0

B = 17 E = 0

Telegram  header Meaning for DPV1 Value range

Device Adr Station address of the slave 0 .. 126

Data Area Unused 0

Data Address Slot 0 .. 254

Data Index Index 0 .. 255

Data Count Data Count 1 .. 240

Data Type Data Type 10

Function Write 2

Send data

Fill in as many data as  the value in data count

Fig. 8-55: Message Monitor – Example DPV 1 Write
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Message Monitor for Testing of DPV1 (at Slave)
In the following, the Message Monitor for reading and writing via DPV1 at
the slave is described.

The following must be entered in the Message Monitor in order to read
data via DPV1 from a slave. For this purpose, first a read message must
have been sent from the master to the slave. The slave creates an
answer as follows:

Message header

Rx = 3 (always) Tx = 255

Ln = (calculated) No = 0 .. 255 (taken from command message)

A = 17 F = 0

B = 0 E = 0

Telegram  header Meaning for DPV1 Value range

Device Adr Station address of the slave 0 .. 126

Data Area Unused 0

Data Address Slot 0 .. 254

Data Index Index 0 .. 255

Data Count Data Count 1 .. 240

Data Type Data Type 10

Function Read 1

Read Data

Fill in as many data as  the value in data count

Fig. 8-56: Message Monitor – Example DPV 1 Read

The following must be entered in the Message Monitor in order to write
data via DPV1 to a slave. For this purpose first a write message must
have been sent from the master to the slave. The slave creates an
answer as follows:

Message header

Rx = 3 (always) Tx = 255

Ln = (calculated) No = 0 .. 255 (taken from command message)

A = 17 F = 0

B = 0 E = 0

Telegram  header Meaning for DPV1 Value range

Device Adr Station address of the slave 0 .. 126

Data Area Unused 0

Data Address Slot 0 .. 254

Data Index Index 0 .. 255

Data Count Data Count 1 .. 240

Data Type Data Type 10

Function Write 2

Fig. 8-57: Message Monitor – Example DPV 1 Write
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9 File, Print, Export and View

9.1 File

Open
An existing project can be opened with File > open.

Save and Save As
When the file name is known, then the configuration can be saved under
the File > Save menu, otherwise the File > Save As menu must be
selected.

Close
The current project can be closed with File > Close.

9.2 Print

After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu.
For a page view, select the File > Page View menu.

pb_7_01d.bmp

Fig. 9-1: File > Print
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The base setting prints information on one sheet only for one device.

Topology prints base information plus the topology of the bus system.

Bus parameters prints also the bus parameters of the bus system.

Address table prints also the address table of the master.

Device table prints also the device table.

The scope can be given with the Device selection menu point. The
following can be chosen:

• All

• From station address to station address

• Selection of a device by means of its description.

9.3 Export Functions

DBM Export
Select the File > Export > DBM menu in order to save the previously
saved project file (*.PB Microsoft Access Format) in a DBM file (Hilscher
binary format). This DBM file can be retrieved in the DOS Compro
program. The configuration is stored in the project directory in the path of
the SyCon installation with the name EXPORT.DBM.

PDD Export
The abbreviation PDD stands for PreDefined Device. The purpose of the
PDD export is to export the configured devices to a file in order to insert,
or copy, them again.

It is recommended to create a sub-directory with the name PDD in the
SyCon directory in order to store the PDD files there.

With the left mouse button, first set the focus (left mouse click) on to the
slave to be exported. Alternatively the master can be selected (again a left
mouse click) in order to export several slaves at the same time.

Select the File > Export > PDD.

pb_7_02d.bmp

Fig. 9-2: PDD Export (1)

Enter the file name. As an example the figure shows the name slave
(.PDD).
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Now select Open. The following figure appears:

pb_7_03d.bmp

Fig. 9-3: PDD Export (2)

For instance, select the device/s from Configured devices (left-hand
side) and pull them to the Devices described in file side (right-hand
side) and release the left mouse button (drag and drop). The following
figure appears:

pb_7_04d.bmp

Fig. 9-4: PDD Export (3)

The figure shows a device with the description "Slave2" consisting of two
modules with the description "Module1" and "Module2".

Select OK in order to write the PDD export into the file.

The symbols have the following meaning:

Symbol Meaning

H Header (file Information)

S Slave

M Module

I Input

O Output

Fig. 9-5: PDD Symbols
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Finally, the path and the file name are given.

pb_7_05d.bmp

Fig. 9-6: PDD Export (4)

9.4 View of the Configuration

Device Table
The View > Device table menu shows the list of all devices that have
been inserted.

pb_7_06d.bmp

Fig. 9-7: View > Device Table
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Address Table
A list of all addresses used in the process depiction is displayed in the
View > Address table menu. For this purpose the current master for
which the table is to be displayed must be chosen.

Addresses refer to the master.

pb_7_07d.bmp

Fig. 9-8: View > Address Table

It is possible to sort the addresses according to station addresses or data
addresses.
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Select the Address Overview button in order to obtain an overview of the
addresses in the input or output region.

pb_7_08d.bmp

Fig. 9-9: View > Address Table > Address Overview

The assignments can be changed here by making the auto addressing
inactive. In order to change the assignment, click with the left mouse
button on a cross and keep the mouse button depressed. The mouse
button changes to an arrow. Pull the arrow (with depressed mouse
button) to the desired (unoccupied) position and release the mouse
button. A confirmation query will appear, whether the change is to be
carried out or not.

The assignment of the offset address can also be carried out via the slave
configuration menu.

The above example shows the moving of a two-byte long module.

Overlapping addresses are shown with a red cross. This means that this
address is used by more than one module.

The information of which Slave occupies a particular address can be seen
by means of a double click on the corresponding cross. The Byte
information window opens.
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10 Tools

10.1 GSD Viewer

The menu Tools > GSD Viewer opens a GSD file to view it.

pb_8_01d.bmp

Fig. 10-1: Tools > GSD Viewer

With More the information e.g. max. number of modules, max. number of
I/O data, max. length of input data and max. length of output data are
displayed.

With Layout the icons for the slave are displayed for

• configuration phase

• run phase

• diagnostic phase

With Identifier the modules of the device and its identifier bytes are
displayed.
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11 Error Numbers

11.1 CIF Device Driver (Dual-Port Memory) Error Numbers
(-1 .. -49)

These is the list of error numbers of Dual-Port Memory access using the
CIF Device Driver.

Error Number Description

-1 Driver: Board not initialized

The communication board is not initialized by the driver.

No or wrong configuration found for the given board, check the driver configuration.

Check the driver function.

-2 Driver: Error in internal ‘Init state‘

-3 Driver: Error in internal ‘Read state‘

-4 Driver: Command on this channel is active

-5 Driver: Unknown parameter in function occurred

-6 Driver: Version is incompatible

The device driver version does not correspond to the driver DLL version. From version V1.200 the
internal command structure between DLL and driver has changed. Make sure to use the same
version of the device driver and the driver DLL.

-10 Device: Dual-Port Memory RAM not accessible (board not found)

Dual-ported RAM (DPM) not accessible / no hardware found.

This error occurs, when the driver is not able to read or write to the Dual-Port Memory.

Check the BIOS setting of the PC memory address conflict with other PC components.

Try another memory address, check the driver configuration for this board, check the jumper setting
of the board.

-11 Device: Not ready (RDY flag=Ready flag failed)

Board is not ready. This could be a hardware malfunction or an other program writes inadmissible to
the Dual-Port Memory.

-12 Device: Not running (RUN flag=Rrunning flag failed)

The board is ready but not all tasks are running, because of an initialization error. No data base is
loaded into the device or a wrong parameter can causes that a task can't initialize.

Fig. 11-1: CIF Device Driver error numbers (-1..-12)
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Error Number Description

-13 Device: Watch dog test failed

-14 Device: Signals wrong operating system version

No license code found on the communication board. Device has no license for the used operating
system or customer software. No firmware or no data base on the device is loaded.

-15 Device: Error in Dual-Port Memory flags

-16 Device: Send mailbox is full

-17 Device: Function PutMessage timeout

No message could be send during the timeout period given in the DevPutMessage() function.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by an other PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set in
the driver setup. These settings have to be the same!

Device internal segment buffer full and therefore PutMessage() function is not possible, because all
segments on the device are in use. This error occurs, when only PutMessage() is used but not
GetMessage().

HOST flag is not set for the device. No messages are taken by the device. Use DevSetHostState() to
signal a board an application is available.

-18 Device: Function GetMessage timeout

No message received during the timeout period given in the DevGetMessage() function.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by an other PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set in
the driver setup. These settings have to be the same!

The used protocol on the device needs longer than the timeout period given in the DevGetMessage()
function.

-19 Device: No message available

Fig. 11-2: CIF Device Driver error numbers (-13..-19)
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Error Number Description

-20 Device: Reset command timeout

The board is ready but not all tasks are running, because of an initialization error. No data base is
loaded into the device or a wrong parameter can cause that a task can’t initialize.

The device needs longer than the timeout period given in the DevReset() function. Using device
interrupts. The timeout period can differ between fieldbus protocols.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by an other PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set in
the driver setup. These settings have to be the same!

-21 Device: COM flag not set

The device can not reach communication state. Device not connected to the fieldbus. No station
found on the fieldbus. Wrong configuration on the device.

-22 Device: IO data exchange failed

-23 Device: IO data exchange timeout

The device needs longer than the timeout period given in the DevExchangeIO() function.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by an other PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set in
the driver setup. These settings have to be the same!

-24 Device: IO data mode unknown

-25 Device: Function call failed

-26 Device: Dual-Port Memory size differs from configuration

-27 Device: State mode unknown

Fig. 11-3: CIF Device Driver error numbers (-20..-27)



11-4 Error Numbers SyConPB

           DOK-CONTRL-SYCON****-DP-AW02-EN-P

Error Number Description

-30 User: Driver not opened (device driver not loaded)

The device driver could not be opened. Device driver not installed. Wrong parameters in the driver
configuration. If the driver finds invalid parameters for a communication board and no other boards
with valid parameters are available, the driver will not be loaded.

-31 User: Can’t connect with device board

-32 User: Board not initialized (DevInitBoard not called)

-33 User: IOCTRL function failed

A driver function could not be called. This is an internal error between the device driver and the DLL.
Make sure to use a device driver and a DLL with the same version. An incompatible old driver DLL is
used.

-34 User: Parameter DeviceNumber invalid

-35 User: Parameter InfoArea unknown

-36 User: Parameter number invalid

-37 User: Parameter mode invalid

-38 User: NULL pointer assignment

-39 User: Messagebuffer too short

-40 User: Size parameter invalid

-42 User: Size parameter with zero length

-43 User: Size parameter too long

-44 User: Device address null pointer

-45 User: Pointer to buffer is a null pointer

-46 User: SendSize parameter too long

-47 User: ReceiveSize parameter too long

-48 User: Pointer to send buffer is a null pointer

-49 User: Pointer to receive buffer is a null pointer

Fig. 11-4: CIF Device Driver error numbers (-30..-49)

1.000 If the operating system of the device reports an initialization error, then a value of 1000 will be add to
the error number and shown to the user
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11.2  CIF Serial Driver Error Numbers (-20 .. -71)

These is the list of error numbers using the serial driver.

Error Number Description

-20 Driver: No COM port found or COM port already in use.

-21 Driver: COM port already opened

-22 Driver: Function call into driver has failed

-23 Driver: Internal driver error

-24 Driver: Could not create read thread

-25 Driver: Could not create read event

-26 Driver: Could not create write event

-27 Driver: Could not create timer event

-28 Driver: Error by writing data

-29 Driver: Wrong COM state

-30 Driver: COM state error is set

-31 Driver: COM buffer setup failed

-32 Driver: COM set timeout failed

-33 Driver: Receive buffer overrun

-34 Driver: Receive buffer full

-35 Driver: Send busy

-36 Driver: Error during close driver

-40 User: COM port not opened

-41 User: Invalid handle value

-42 User: Invalid COM number

-43 User: Size parameter invalid

-44 User: Size parameter zero

-45 User: Buffer pointer is NULL

-46 User: Buffer too short

-47 User: Setup error

Fig. 11-5: CIF Serial Driver error numbers  (-20..-47)
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Error Number Description

-50 User: Send message, timeout error

-51 User: Could not send a message

Cable not connected.

Wrong cable.

Device does not respond.

-52 User: Send message, no device connected

-53 User: Error by send message, message receiving

-54 User: Telegram collision

-55 User: Telegram, no acknowledgement received

-56 User: Telegram, noise

-57 User: Telegram, data overrun

-58 User: Telegram, parity error

-59 User: Telegram, framing error

-60 User: Telegram, unknown error

-70 User: Timeout by receive a message

-71 User: No message received

Fig. 11-6: CIF Serial Driver error numbers  (-50..-71)
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11.3 RCS Error Numbers (4 .. 93)

This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of Hilscher devices.
The error number is returned in an answer message. Command
messages and answer messages are used to communicate between the
application (e.g. the system configurator) and the Hilscher device. An
example of this communication is the download of a configuration.

Error Number Description

4 Task does not exist

5 Task is not initialized

6 The MCL is locked

7 The MCL rejects a send command because of an error

20 The user will download a database into the device that is not valid for this device type.

21 Data base segment not configured or not existent

22 Number for message wrong during download

23 Received number of data during download does not match to that in the command message

24 Sequence identifier wrong during download

25 Checksum after download and checksum in command message do not match

26 Write/Read access of data base segment

27 Download/Upload or erase of configured data base type is not allowed

28 The state of the data base segment indicated an error. Upload not possible

29 The access to the data base segment needs the bootstraploader. The bootstraploader is not present

30 Trace buffer overflow

31 Entry into trace buffer too long

37 No or wrong license. The OEM license of the system configurator allows only communication to
devices that have the same license inside

38 The data base created by the system configurator and the data base expected by the firmware is not
compatible

39 DBM module missing

Fig. 11-7: RCS error numbers (answer message) (4..39)
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Error Number Description

40 No command free

41 Command unknown

42 Command mode unknown

43 Wrong parameter in the command

44 Message length does not match to the parameters of the command

45 Only a MCL does use this command to the RCS

50 FLASH occupied at the moment

51 Error deleting the FLASH

52 Error writing the FLASH

53 FLASH not configured

54 FLASH timeout error

55 Access protection error while deleting the FLASH

56 FLASH size does not match or not enough FLASH memory

60 Wrong structure type

61 Wrong length of structure

62 Structure does not exist

70 No clock on the device

80 Wrong handle for the table (table does not exist)

81 Data length does not match the structure of this table

82 The data set of this number does not exist

83 This table name does not exist

84 Table full. No more entries allowed

85 Other error from DBM

90 The device info (serial number, device number and date) does already exist

91 License code invalid

92 License code does already exist

93 All memory locations for license codes already in use

Fig. 11-8: RCS error numbers (answer message) (40..93)
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11.4 Database Access Error Numbers (100 .. 130)

The following table lists the error numbers of the database access errors.

Error Number Description

100 Database already opened

101 Dataset could not be opened

103 Error while opening database occurred

104 No valid path name

105 No connection to data base. Call function DbOpen().

106 Error in parameter

107 Error during opening a table

108 Nullpointer occurred

109 Table not opened. Call function OpenTable() first.

110 The first record is reached

111 The last record is reached

112 Unknown type in the record found

113 Data has to be truncated

114 No access driver installed on the system

115 Exception received

116 This table is set to read only

117 There is no data set in the table

118 The requested table could not be edit

119 An operation could not be completed

120 User gives an unexpected length in WritsDs().

121 An assertion failed

122 DLL not found

123 DLL couldn’t be freed

124 Specified function not found in the DLL

125 ODBC function returns an error

126 Count of data bytes in the record exceeds 1938

127 DBM32 DLL is not loaded

128 Field with the given index was not found

129 This table contains no records

130 Invalid character (’ ’) found in a table or column

Fig. 11-9: Database access error numbers (100..130)
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11.5 Online Data Manager Error Numbers

Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the online data manager.

Error Number Description

1000 Driver OnlineDataManager not opened

1001 Initialization of the OnlineDataManager has failed

1002 No DriverObject found. OnlineDataManager Sub DLL not found.

1003 No DeviveObject found. Device not found.

1004 Application not found

1010 Application has requested an unknown event

1011 Application has requested an unknown function mode, operating mode. Known function modes,
operating modes are Reset, Download, Register Server, Unregister Server.

1012 Application has requested an unknown command

1013 Message server already exists

1014 Message server not registered

1015 Device already in use

1016 Device not assigned

1017 Device has changed

1018 Command active

Fig. 11-10: Online data manager error numbers (1000..1018)

Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the message handler of the
online data manager.

Error Number Description

2010 Message handler: Message buffer empty

2011 Message handler: Message buffer full

2021 Message handler: Invalid Message ID (msg.nr)

2022 Message handler: No entry

2023 Message handler: Message already active

2024 Message handler: Wrong application

2025 Message handler: Message timeout

2026 Message handler: Wait for delete

2027 Message handler: No cyclic message

Fig. 11-11: Message handler error numbers of the online data manager 
(2010..2027)
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Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the driver functions of the
online data manager.

Error Number Description

2501 OnlineDataManager Sub DLL not found

2502 Function missing

2503 ’Read Thread’ not created

2504 ’Write Thread’ not created

2505 ’IO Thread’ not created

2510 Function failed

2512 Assign reports error. Return neither OK or cancel

Fig. 11-12: Error numbers of the driver functions of the online data manager
(2501..2512)

Online Data Manager Subfunctions Error Numbers (8001 .. 8035)
The following table lists the error numbers of the subfunctions of the
online data manager.

Error Number Description

8001 Driver not opened. E.g. CIF Devive Driver

8002 Application has requested an unknown event

8003 Application has requested an unknown command

8004 Command has failed

8005 Command active

8006 Device invalid

8010 No device was assigned

8011 Device was already assigned

8020 Driver not connected

8021 Driver already connected

8030 Faulty ’GetState’

8031 Send error (PutMessage returns error)

8032 Send active (PutMessage active)

8033 Receive error (GetMessage returns error)

8034 Receive active (GetMessage active)

8035 IO Error (ExchangeIO returns error)

Fig. 11-13: Subfunction Error Numbers of the Driver Functions of the Online
Data Manager (8001..8035)



11-12 Error Numbers SyConPB

           DOK-CONTRL-SYCON****-DP-AW02-EN-P

11.6 Database Functions Error Numbers (4000 .. 4098)

The following table lists the error numbers of the database functions.

Error Number Description

4000 File does not exist

4001 Success in comprimizing

4002 Dataset does not exist

4003 Last respectively first entry reached

4004 Not enough memory

4005 File directory full

4006 Max. number of entries reached

4007 No writing to this table possible, because the table is located in the FLASH

4008 Table name does already exist

4009 File name does not exist

4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2

4011 Parameter ‘next’ wrong

4012 Not enough free space to copy data set

4013 Set is deleted

4014 Value for index is wrong

4015 Access not allowed

4016 open_file used before init_file

4017 Drive is not ready

4018 Not enough drive memory

4019 File name or path does not exist

4020 Cannot create path

4021 Wrong path

4022 Wrong flag

4023 The delete path is the root path

4024 Path file exists

4025 Write error during write a file

4026 Error during create a file

4027 Error during close a file

4028 No DBM file

4029 Length of the read data is unequal of the file length

Fig. 11-14: Error numbers of the database functions (4000..4029)
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Error Number Description

4030 Path too long

4031 Directory changed

4032 Directory created

4034 Length of converting stream is 0

4035 Non equal data set found

4036 Non equal data set found

4037 Non equal data set found

4038 Data set has length 0

4039 The function DbmInit has assigned a Zero pointer during RCS initialization

4040 Printer not ready

4041 The data base is used from an other function

4042 New length of data base is smaller than used

4043 Unknown access mode

4044 Old data base has to be converted

4045 Error while converting. Function not known

4046 Unknown type in set 0 found

4047 No float function available

4048 Function not in RCS module

4049 Check failed

4050 Checksum check failed

4051 More segments are existing in file, than in the structure FILE_INFO_T in wMax entries

4052 SegLen in structure FILE_INFO_T is smaller then the length in the file. Return of function
dbm_restore_data

4053 The header file holds an other information for a length than in the segment itself

4054 Not enough memory for allocation on the PC

4055 No index for file handle in structure FLASH_DIR of RCS found

4056

4057 File type 2 can not be printed because of too many definitions

4058 The definitions need too many lines to display them, than in the program available

4059 An unknown format for the parameter. Valid is U, H, or S

4060 Unknown parameter type

Fig. 11-15: Error numbers of the database functions (4030..4060)
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Error Number Description

4061 The data base was transmitted into the FLASH

4062 Set 0 contains no structure definition

4063 Set 0 can not be deleted

4064 Error during execution of a ODBC data base access

4065 Initializing of DBM through RCS had no success

4066 Passed data length incorrect

4067 Sorting function not linked

4068 Error in function parameter

4069 Error from ODBC table

4070 No free handle available. Too many data base links are already opened

4071 Unknown data type found in the table

4072 Structure of table GLOBAL not correct or no such table existing

4073 No name of an ACCESS data base

4074 Download window can’t be created

4075 Download not fully performable

Fig. 11-16: Error numbers of the database functions (4061..4075)
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Error Number Description

4082 More than 32 tables should be created

4083 No entry in element szSourceFile

4084 ODBC connection initialization not possible. This could happen when in file ODBCINST.INI in section
[Microsoft Access Driver (*.mdb)] is no valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format

4086 Error in structure in the ACCESS data base that is in DBM format

4087 No data in a ODBC table

4088 No entry

4089 ODBC set length not valid

4090 Not enough data sets in ODBC table

4091 Table CreateTab not found

4092 Error in structure of table CreateTab

4093 No entry in element szSourceTable

4094 No entry in element szDestTable

4095 Entry in iSourceType of table CreateTab is wrong

4096 Entry in iTranslate of table CreateTab is wrong

4097 Function SQLAllocStmt reports an error

4098 ODBC source table not found

4099 ODBC data truncated

4100 Download timeout

4101 Library load error

4102 Library function error

4103 Error in description ’toggle’

1104 Error in description ’KB’

4105 Column does not exist

4106 ODBC structure different

4107 ODBC address error

4108 No CRC sum exists (table GLOBAL exists or old)

4109 Table GLOBAL is old

4110 Calculated CRC different to CRC in table GLOBAL

4199 Programming error

Fig. 11-17: Error numbers of the database functions (4082..4199)
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11.7 Converting Functions Error Numbers (5001 .. 5008)

The following table lists the error numbers of converting functions.

Error Number Description

5000 Function PackLongToByteShort: Not enough space in pvD (number of elements greater than
reserved memory)

5001 Function PackLongToByteShort: Not enough space in pvD. Detected during converting of pvS

5002 Function PackLongToByteShort: Not enough space in pvD

5003 Function StringToByte: Not enough space in pvD

5004 Function IntToByte: Not enough space in pvD

5005 Function LongToShort: Not enough space in pvD

5006 Function PackStringDumpToByteArray: Not enough space in pvD

5007 Function PackStringBumpToByteArray: A character was found, which is not convertible into a HEX
value

5008 Function PackStringDumpToByteArray: Number of character odd

5009 Function PackStringDumpToByteArray: Not enough space in pvD

5010 Function PackStringDumpToByteArray: The current data set needs to be appended the previous one

5011 Function PackStringDumpToByteArray: No corresponding function to the given number exist

5012 Converting error

Fig. 11-18: Error numbers of converting functions (5000..5012)
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12 Description of the Dual-Port Memory DPM

12.1 General Information

For data exchange between the PLC and the PROFIBUS connection a
Dual-Port Memory of size 8 kbyte is available on the controller board. It is
divided up as follows:

512 bytes outputs

512 bytes inputs

Send mailbox

Parameter and
status information

Handshakebytes
for synchronization

PLC DPM on PROFIBUS controller board PROFIBUS

Receive mailbox

Aufteilung_DPM.FH7

Fig. 12-1: Overview Dual-Port Memory

12.2 Memory Distribution DPM

In the PLC programming interface there is the possibility to access all
memory areas of the DPM via absolute addressing. The corresponding
variables have to be entered in the VAR area of the declaration editor
(e.g.: variable AT %PB*.*). The following tables specify the addresses of
the single memory areas.

Address area

(decimal)

Address area

(hexadecimal)

Size Designation

0 - 511 0000 - 01FF 512 bytes

SndPd

Process output data

PLC Å PROFIBUS

512 - 3583 0200 - 00DFF 3 kbyte Free

3584 - 4095 0E00 - 0FFF 512 bytes

RecvPd

Process input data

PROFIBUS Å PLC

4096 - 7167 1000H - 1BFF 3 kbyte Free

Fig. 12-2: Addresses of DP Master input and output data
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Address area

(decimal)

Address area

(hexadecimal)

Size Designation

0 - 6143 0000 - 17FF 6 kbyte Free

6144 - 6655 1800 -19FF 512 bytes

SndPd

Process output data

PLC Å PROFIBUS

6656 - 7167 1A00 -1BFF 512 bytes

RecvPd

Process input data

PROFIBUS Å PLC

Fig. 12-3: Addresses of DP Slave input and output data

Address area
(hexadecimal)

Size Designation

1C00H -1D1FH 288 bytes DevMailbox[288] Message Buffer
HOST → DEVICE

1D20H-1D23H 4 bytes Date[4] Information Device

1D24H-1D27H 4 bytes DeviceNumber[4]

1D28H-1D2BH 4 bytes SerialNumber[4]

1D2CH-1D2FH 4 bytes reserved[4]

1D30H-1D33H 4 bytes PcOsName0[4] Information Driver

1D34H-1D37H 4 bytes PcOsName1[4]

1D38H-1D3BH 4 bytes PcOsName2[4]

1D3CH-1D3FH 4 bytes OemIdentifier[4]

1D40H-1E5FH 288 bytes
HostMailbox[288]
Message Buffer

DEVICE → HOST

1E60H-1E6FH 16 bytes FirmwareName[16]
Information Firmware

1E70H-1E7FH 16 bytes FirmwareVersion[16]

1E80H-1EBFH 64 bytes Task1Parameter[64]
Parameters of Task 1, 2

1EC0H-1EFFH 64 bytes Task2Parameter[64]

1F00H-1F3FH 64 bytes Task1State[64]

States of Task 1, 2

1F40H-1F7FH 64 bytes Task2State[64]

1F80H-1F87H 8 bytes Task1Name[8]
Information Task 1

1F88H integer Task1Version

1F8AH byte Task1State

1F8BH-1F8FH bytes reserved5

1F90H-1F97H bytes Task2Name[8] 8
Information Task 2

1F98H integer Task2Version

1F9AH byte Task2Condition

1F9BH-1F9FH bytes reserved5

1FA0H-1FA7H 8 bytes Task3Name[8]
Information Task 3

1FA8H integer Task3Version

1FAAH byte Task3Condition
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1FABH-1FAFH bytes reserved5

1FB0H-1FB7H 8 bytes Task4Name[8]
Information Task 4

1FB8H integer Task4Version

1FBAH byte Task4Condition

1FBBH-1FBFH bytes reserved5

1FC0H-1FC7H 8 bytes Task5Name[8]
Information Task 5

1FC8H integer Task5Version

1FCAH byte Task5Condition

1FCBH-1FCFH bytes reserved5

1FD0H-1FD7H bytes Task6Name[8] 8
Information Task 6

1FD8H integer Task6Version

1FDAH byte Task6Condition

1FDBH-1FDFH bytes reserved5

1FE0H-1FE7H 8 bytes Task7Name[8]
Information Task 7

1FE8H integer Task7Version

1FEAH byte Task7Condition

1FEBH-1FEFH bytes reserved5

1FF0H integer RcsVersion
Information Operating System

1FF2H byte RcsError

1FF3H byte HostWatchDog

1FF4H byte DevWatchDog

1FF5H byte SegmentCount

1FF7H byte DriverType

1FF8H byte DpmSize
Information of the Device

1FF9H byte DevType

1FFAH byte DevModel

1FFBH-7FDH 3 bytes DevIdentifier[3]

1FFEH byte
HostFlags

Command and Acknowledge Location
DEVICE → HOST

1FFFH byte
DevFlags

Command and Acknowledge Location
HOST → DEVICE

Fig. 12-4: Addresses DP Master/Slave
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The memory areas have the following function:

In this area you will find the process data to be send.

In this area you will find the received process data.

The data to be send to the controller board are written in this memory
area.

In this memory area the messages send from the controller board are
available in a defined message format.

This two memory areas allow the mutual monitoring between the PLC
user program (HOST) and the controller board (DEVICE). For this, the
controller board reads out the value of the DevWatchDog, increments this
value and writes the increased value back in the HostWatchDog. A value
of 255 is not incremented to 0, but to 1. The operation incrementing and
writting back is executed within 20ms. The monitoring is only active when
the value in the DevWatchDog is unequal to 0. After initializing the
controller board the value in the DevWatchDog area is 0 so that the
monitoring function is deactivated. Thus, the user can switch on or off this
monitoring via the PLC program.

Number of still available memory segments to receive buffered
messages. This value is entered by the controller board.

Monitoring of data exchange between host and controller board. The
controller board describes the HostFlags; the Host reads out only the
HostFlags. The Host describes the DevFlags; the controller board reads
out the DevFlags.

SndPd:

RecvPd:

DevMailbox:

HostMailbox:

HostWatchDog/DevWatchDog:

SegmentCount:

HostFlags/DevFlags:
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13 Firmware Functions and Function Blocks

Note: With the change to the PLC programming interface, Version
21, the interfaces as well as the designations of functions and
function blocks have been changed:
All FKs/FBs have no longer an input ’MODUL’ (type: USINT)
The naming changes from DP_xx to DPM_xx.

The following description of the FKs/FBs and the program example refer
to versions prior than version 21.

The description and the program example are also valid for versions
developed later than version  21, when the above mentioned changes are
considered.

13.1 Firmware Data Types

The following data types are available:

• Status information of PROFIBUS: DPGLOBAL

• Status bits of a PROFIBUS Slave: DPSLDIAG

Status Information of PROFIBUS DPGLOBAL
The Firmware data type DPGLOBAL is an Array of BOOL that indicates
the status bits of the PROFIBUS. The array consists of the following
elements:

Control Error: error in parameterization

Autoclear Error: master has stopped communication with all slaves.

Non Exchange Error: at least one slave has not reached the data
exchange status. There’s no process data exchange with this slave.

Fatal Error: no bus communication available because of a fatal bus error
(e.g. bus short circuit). An unplug of the bus cable is not recognized.

Event Error: master recognized bus short circuits. The number of short
circuits is saved in variable "bus_error_cnt". This bit won’t be self-deleted.

Host Not Ready Notification: user program indicates "not ready".

Timeout Error: master detects timeout because of refused telegrams.
This bit won’t be self-deleted.

CTRL:

ACLR:

NEXC:

FAT:

EVE:

NRDY:

TOUT:
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Slave Status Bits DPSLDIAG
The firmware data type DPSLDIAG is an array that indicates the status
bits of a PROFIBUS Slave. The array consists of the following elements:

DP Slave does not respond

DP Slave not ready

DP Slave incorrectly parameterized

DP Slave indicates extended diagnosis

DP Slave indicates invalid command

Invalid DP Slave response

Last parameter telegram incorrect

DP Slave parameterized by another master

DP Slave not yet parameterized

DP Slave diagnosis available

Reserved

Watchdog of DP Slave activated

Freeze command active

Sync command active

Reserved

DP Slave not projected

Reserved

Reserved

Reserved

Reserved

Reserved

Reserved

Reserved

’Data area overflow’ extended diagnosis

Address of parameterized DP Master

Ident number of DP Slave

StaNonEx:

StaNotRd:

CfgFault:

ExtDiag:

NotSupp:

InvSlRes:

PrmFault:

MastLock:

PrmReq:

StatDiag:

S2_D2:

WDOn:

FreezeMd:

SyncMd:

S2_D6:

Deaktiv:

S3_D0:

S3_D1:

S3_D2:

S3_D3:

S3_D4:

S3_D5:

S3_D6:

ExtDiag0:

MastAdd:

IdentNo:
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13.2 Functions

The following functions are available:

• Start bus communication: DP_START

• Stop bus communication: DP_STOP

• Status information via PROFIBUS process data exchange:
DP_EXCHG

Start Bus Communication DP_START
With this function the PROFIBUS is switched in operating mode
OPERATE and the communication between master and slaves is started.

Note: System configurator SyCon allows to set the starting behavior
of the PROFIBUS after the system initialization. If "Automatic
enable of the communication by the system" is set, the bus
communication is automatically started after each PLC
program download (CTRL-F9) or after each configuration
download by the SyCon. However, the setting "Controlled
enable of the communication by the user program" causes
that the bus communication has to be started explicitly with
block DP_START. For further information refer to DP Master
Settings on page 7-10 and DP Slave Settings on page 7-15.

The slot number of the PC104 PROFIBUS connection is applied to the
input ’MODUL’. If input ’START’ becomes TRUE, the bus communication
is started. If the start is successful, the function result is TRUE.

If an invalid value (0 or ≥5) is applied to input ’MODUL’, the error variables
are set as follows:

ErrorFlg: TRUE

ErrorNr:         1

ErrorTyp:    -244

If a wrong slot number is indicated or there’s no PROFIBUS connection
the ErrorNo is set on 235; the other error variables are set as specified
above.

              ¿©©©©©©©©¤  
              �DP_START�  
      BOOL ©©©�START   ¨©©© BOOL
     USINT ©©©�MODUL   �  
              ¥©©©©©©©©¾  

START  (BOOL): Activates the operating mode OPERATE
MODUL (USINT):    Module number (slot number of PROFIBUS PC104 

connection)

Error Variables
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Stop Bus Communication DP_STOP
With this function the PROFIBUS is switched in the operating mode
STOP and the communication between master and slaves is stopped.

The slot number of the PC104 PROFIBUS connection is applied to input
’MODUL’. If input ’STOP’ becomes TRUE, the bus communication is
stopped. If the function is successfully executed, the function result
becomes TRUE.

If an invalid value (0 or ≥5) is applied to input ’MODUL’ the error variables
are set as follows:

ErrorFlg: TRUE

ErrorNr:         1

ErrorTyp:    -243

If a wrong slot number is indicated or there’s no PROFIBUS connection,
the ErrorNr is set on 235; the other error variables are set as specified
above.

              ¿©©©©©©©©¤  
              �DP_STOP �  
      BOOL ©©©�STOP    ¨©©© BOOL
     USINT ©©©�MODUL   �  
              ¥©©©©©©©©¾  

STOP  (BOOL): Activates operating mode STOP
MODUL (USINT):    Module number (Slot number of PROFIBUS PC104 

connection)

Status Information on Process Data Exchange DP_EXCHG
This function provides the status information about the PROFIBUS
process data exchange. If the data exchange is active with at least one
slave, the function result is TRUE.

If an invalid value (0 or ≥5) is applied to input ’MODUL’ the error variables
are set as follows:

ErrorFlg: TRUE

ErrorNr:         1

ErrorTyp:    -245

If a wrong slot number is indicated or there’s no PROFIBUS connection
the ErrorNr is set on 235; the other error variables are set as specified
above.

              ¿©©©©©©©©©¤  
              �DP_EXCHG �  
      BOOL ©©©�READ     ¨© BOOL
     USINT ©©©�MODUL    �  
              ¥©©©©©©©©©¾  

READ   (BOOL): Read status
MODUL (USINT):    Module number (slot number of PROFIBUS PC104 

connection)

Error Variables

Error Variables
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13.3 Function Blocks

The following function blocks are available:

• Status information of PROFIBUS Master: DP_STATE

• Single diagnosis of a PROFIBUS Slave: DP_SLDIAG

Status Information of PROFIBUS Master DP_STATE
This function block provides the status information of the PROFIBUS DP
Master, if the Boolean input ’READ’ is assigned to TRUE. Furthermore,
the slot number of the PC104 PROFIBUS connection has to be assigned
to the input ’MODUL’.

The outputs contain the following information:

OFFLINE: The PROFIBUS is in operating mode OFFLINE

STOP:   The PROFIBUS is in operating mode STOP

CLEAR: The PROFIBUS is in operating mode CLEAR

OPERATE: The PROFIBUS is in operating mode OPERATE

GLOBAL: Global status information of the PROFIBUS

SL_CFG: List of the configured slaves

SL_STATE: List of the active slaves

SL_DIAG: List of the slaves for diagnosis (deleting the entries
occurs by prompting the slave single diagnosis (see 0:
Single Diagnosis of PROFIBUS Slave DP_SLDIAG).

READY: Function block is processed

                ¿©©©©©©©©©©©©©©©©©©©¤
                �DP_STATE           �
                �                   � 
        BOOL  ©©�READ        OFFLINE¨© BOOL
        USINT ©©�MODUL          STOP¨© BOOL
                �              CLEAR¨© BOOL
                �            OPERATE¨© BOOL
                �             GLOBAL¨© DPGLOBAL
                �             SL_CFG¨© A_B127
                �           SL_STATE¨© A_B127
                �            SL_DIAG¨© A_B127
                �              READY¨© BOOL
                ¥©©©©©©©©©©©©©©©©©©©¾ 

READ (BOOL): Read status
MODUL (USINT): PC104 slot number of the PROFIBUS connection
OFFLINE (BOOL): Operating mode OFFLINE
STOP (BOOL): Operating mode STOP
CLEAR (BOOL): Operating mode CLEAR
OPERATE (BOOL): Operating mode OPERATE
GLOBAL (DPGLOBAL): Global status bits
SL_CFG (A_B127): Table of configured slaves
SL_STATE (A_B127): Table of active slaves
SL_DIAG (A_B127): Table of slaves with diagnosis
READY (BOOL): Function block is processed

If an invalid value (0 or ≥5) is applied to input ’MODUL’ the error variables
are set as follows:

ErrorFlg: TRUE

ErrorNr:         1

ErrorTyp:    -242

If a wrong slot number is indicated or there’s no PROFIBUS connection
the ErrorNr is set on 235; the other error variables are set as specified
above.

Error Variables
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Single Diagnosis of PROFIBUS Slave DP_SLDIAG
The diagnostic information of a DP Slave consist of standard diagnostic
information and (if available) user-specific diagnostic information. This
function block provides the standard diagnosis of the slave addressed via
input ’SLV_ADR’ at output ’DIAG’. If the master is in operating mode
OPERATE, user-specific diagnostic information are provided at output
’EX_DIAG’. The length (in byte) of this information is specified at output
’EX_LEN’.

Note: The bus should not be unnecessarily charged. For this reason,
the diagnosis should only be requested when the
corresponding bit in the diagnostic array has been set by
function block DP_State (see chapter 13.4: Program
Example). By reading the diagnosis this bit is deleted again in
the diagnostic array.

Furthermore, this function block is to implement only in
controls with DP Master configuration.

If an invalid value (0 or ≥5) is applied to input ’MODUL’ the error variables
are set as follows:

ErrorFlg: TRUE

ErrorNr:        1

ErrorTyp:    -239

If a wrong slot number is indicated or there’s no PROFIBUS connection
the ErrorNr is set on 235; the other error variables are set as specified
above.

              ¿©©©©©©©©©©©©©©©©©©©¤ 
              �DP_SLDIAG          � 
              �                   � 
       BOOL  ©�READ           DIAG¨© DPSLDIAG
       USINT ©�SLV_ADR     EX_DIAG¨© A_BY26
       USINT ©�MODUL        EX_LEN¨© USINT
              �              READY¨© BOOL
              ¥©©©©©©©©©©©©©©©©©©©¾ 

READ     (BOOL): Read diagnosis
SLV_ADR (USINT): Slave address
MODUL   (USINT): PC104 slot number of the PROFIBUS connection
DIAG (DPSLDIAG): Diagnosis of the addressed slaves
EX_DIAG A_BY26): Extended diagnosis data
EX_LEN  (USINT): Length of the extended diagnosis data
READY    (BOOL): Function block is processed

Error Variables
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13.4 Program Example

In this program example the single diagnosis of the slave is read with
address 15. The PC104 PROFIBUS connection is located on slot 2. The
bus can be started with variable dp_start and stopped with variable
dp_stop. If the master recognizes a diagnosis of the slave, the bit
Sl_Diag[15] is set. With variable read_diag the status bits of the diagnosis
set in array diag15 can be read. By reading the diagnosis bit SL_Diag[15]
is deleted again.
 �           ¿©©©©©©©©¤                                      �
 �dp_start   �DP_START�                             start_rdy�
 ¨� ¨©©©©©©©©�START   ¨©©©©©©©©©©©©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �         2©�MODUL   �                                      �
 �           ¥©©©©©©©©¾                                      �
 dp_start... Start bus....  .................. ........ BOOL
 DP_START... ................................. ........ DP_START
 start_rdy.. Bus started...................... ........ BOOL
 2.......... PC104 slot number of PROFIBUS DP.......... USINT

 �           ¿©©©©©©©©¤                                      �
 �dp_stop    �DP_STOP �                             stop_rdy �
 ¨� ¨©©©©©©©©�STOP    ¨©©©©©©©©©©©©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �         2©�MODUL   �                                      �
 �           ¥©©©©©©©©¾                                      �
 dp_stop... Stop bus .................................. BOOL
 DP_STOP... ........................................... DP_STOP
 stop_rdy.. Bus stopped ............................... BOOL
 2......... PC104 slot number of PROFIBUS DP........... USINT

 �(*Status information PROFIBUS Master*)                     �
 �           dp_master                                       �
 �           ¿©©©©©©©©©©©©©©©©©©©¤                           �
 �           �DP_STATE           �                           �
 �           �                   �                  offline  �
 ¨©©©©©©©©©©©�READ        OFFLINE¨©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �           �                   �                  stop     �
 �         2©�MODUL          STOP¨©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �           �                   �                  clear    �
 �           �              CLEAR¨©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �           �                   �                  operate  �
 �           �            OPERATE¨©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �           �             GLOBAL¨©global                    �
 �           �             SL_CFG¨©Sl_Cfg                    �
 �           �           SL_STATE¨©Sl_State                  �
 �           �            SL_DIAG¨©Sl_Diag                   �
 �           �                   �                  ready    �
 �           �              READY¨©©©©©©©©©©©©©©©©©©( )©©©©©©�
 �           ¥©©©©©©©©©©©©©©©©©©©¾                           �
 dp_master.. Status information DP Master............ DP_STA
 offline.... Operating state OFFLINE................. BOOL
 2.......... PC104 slot number of PROFIBUS DP........ USINT
 stop....... Operating state STOP.................... BOOL
 clear...... Operating state CLEAR................... BOOL
 operate.... Operating state OPERATE................. BOOL
 global..... Global status bits...................... DPGLOB
 Sl_Cfg..... List of configured slaves. ............. A_B127
 Sl_State... List of active slaves...... ............ A_B127
 Sl_Diag.... List of slaves with diagnosis........... A_B127
 ready...... ........................................ BOOL

 �(*Slave-Einzeldiagnose*)                                   �
 �                      diag_sl15                            �
 �                      ¿©©©©©©©©©©©©©©©©©©©¤                �
 �                      �DP_SLDIAG          �                �
 �read_diag  Sl_Diag[15]�                   �                �
 ¨� ¨©©©©©©©©©©©� ¨©©©©©�READ           DIAG¨©diag15         �
 �                   15©�SLV_ADR     EX_DIAG¨©ex_diag15      �
 �                    2©�MODUL        EX_LEN¨©ex_len15       �
 �                      �                   �        diag_rdy�
 �                      �              READY¨©©©©©©©©( )©©©©©�
 �                      ¥©©©©©©©©©©©©©©©©©©©¾                �
 diag_sl15.... Slave single diagnosis address 15....... DP_SLDIAG
 read_diag.... Read diagnosis.......................... BOOL
 Sl_Diag[15].. Diagnosis of slave 15 recognized........ BOOL
 diag15....... Status bits of diagnosis................ DPSLDIAG
 15........... Address of slave ANY IN to be diagnosed. ANY_IN
 ex_diag15.... Extended diagnosis data address 15...... A_BY26
 2............ PC104 slot number of PROFIBUS DP........ USINT
 ex_len15..... Length of extended diagosis data........ USINT
 diag_rdy..... Diagnosis has been read................. BOOL
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15 Service & Support

15.1 Helpdesk

Unser Kundendienst-Helpdesk im Hauptwerk Lohr
am Main steht Ihnen mit Rat und Tat zur Seite.
Sie erreichen uns

- telefonisch: +49 (0) 9352 40 50 60
über Service Call Entry Center Mo-Fr   07:00-18:00

- per Fax: +49 (0) 9352 40 49 41

- per e-Mail: service@indramat.de

Our service helpdesk at our headquarters in Lohr am
Main, Germany can assist you in all kinds of inquiries.
Contact us

- by phone: +49 (0) 9352 40 50 60
via Service Call Entry Center Mo-Fr 7:00 am - 6:00 pm

- by fax: +49 (0) 9352 40 49 41

- by e-mail: service@indramat.de

15.2 Service-Hotline

Außerhalb der Helpdesk-Zeiten ist der Service
direkt ansprechbar unter

+49 (0) 171 333 88 26
oder +49 (0) 172 660 04 06

After helpdesk hours, contact our service
department directly at

+49 (0) 171 333 88 26
or +49 (0) 172 660 04 06

15.3 Internet

Unter www.indramat.de finden Sie
ergänzende Hinweise zu Service, Reparatur und
Training sowie die aktuellen Adressen *) unserer
auf den folgenden Seiten aufgeführten Vertriebs-
und Servicebüros.

Verkaufsniederlassungen

Niederlassungen mit Kundendienst

Außerhalb Deutschlands nehmen Sie bitte zuerst Kontakt mit
unserem für Sie nächstgelegenen Ansprechpartner auf.

*) http://www.indramat.de/de/kontakt/adressen
Die Angaben in der vorliegenden Dokumentation können
seit Drucklegung überholt sein.

At www.indramat.de you may find additional
notes about service, repairs and training in the
Internet, as well as the actual addresses *) of our
sales- and service facilities figuring on the following
pages.

sales agencies

offices providing service

Please contact our sales / service office in your area first.

*) http://www.indramat.de/en/kontakt/adressen
Data in the present documentation may have become
obsolete since printing.

15.4 Vor der Kontaktaufnahme... - Before contacting us...

Wir können Ihnen schnell und effizient helfen wenn
Sie folgende Informationen bereithalten:

1. detaillierte Beschreibung der Störung und der
Umstände.

2. Angaben auf dem Typenschild der betreffenden
Produkte, insbesondere Typenschlüssel und
Seriennummern.

3. Tel.-/Faxnummern und e-Mail-Adresse, unter
denen Sie für Rückfragen zu erreichen sind.

For quick and efficient help, please have the
following information ready:

1. Detailed description of the failure and
circumstances.

2. Information on the type plate of the affected
products, especially type codes and serial
numbers.

3. Your phone/fax numbers and e-mail address,
so we can contact you in case of questions.
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15.5 Kundenbetreuungsstellen - Sales & Service Facilities

Deutschland – Germany vom Ausland: (0) nach Landeskennziffer weglassen!
from abroad: don’t dial (0) after country code!

Vertriebsgebiet Mitte
 Germany Centre

Rexroth Indramat GmbH
Bgm.-Dr.-Nebel-Str. 2 / Postf. 1357
97816 Lohr am Main / 97803 Lohr

Kompetenz-Zentrum Europa

Tel.: +49 (0)9352 40-0
Fax: +49 (0)9352 40-4885

S E R V I C E

C A L L  E N T R Y  C E N T E R
MO – FR

von 07:00 - 18:00 Uhr

from 7 am – 6 pm

Tel. +49 (0) 9352 40 50 60
service@indramat.de

S E R V I C E

H O TLIN E
MO – FR

von 17:00 - 07:00 Uhr
from 5 pm - 7 am

+ SA / SO

Tel.: +49 (0)172 660 04 06
oder  /  o r

Tel.: +49 (0)171 333 88 26

S E R V I C E

ERSATZTEILE / SPARES
verlängerte Ansprechzeit
- extended office time -

♦ nur an Werktagen
- only on working days -

♦ von 07:00 - 18:00 Uhr
- from 7 am - 6 pm  -

Tel. +49 (0) 9352 40 42 22

Vertriebsgebiet Süd
 Germany South

Rexroth Indramat GmbH
Landshuter Allee 8-10
80637 München

Tel.: +49 (0)89 127 14-0
Fax: +49 (0)89 127 14-490

Gebiet Südwest
 Germany South-West

Bosch Rexroth AG
Vertrieb Deutschland – VD-BI
Geschäftsbereich Rexroth Indramat
Regionalzentrum Südwest
Ringstrasse 70    /   Postfach 1144
70736 Fellbach   /    70701 Fellbach

Tel.: +49 (0)711 57 61–100
Fax: +49 (0)711 57 61–125

Vertriebsgebiet Ost
 Germany East

Bosch Rexroth AG
Beckerstraße 31
09120 Chemnitz

Tel.: +49 (0)371 35 55-0
Fax: +49 (0)371 35 55-333

Vertriebsgebiet Ost
 Germany East

Bosch Rexroth AG
Regionalzentrum Ost
Walter-Köhn-Str. 4d
04356 Leipzig

Tel.: +49 (0)341 25 61-0
Fax: +49 (0)341 25 61-111

Vertriebsgebiet West
 Germany West

Bosch Rexroth AG
Vertrieb Deutschland
Regionalzentrum West
Borsigstrasse 15
40880 Ratingen

Tel.: +49 (0)2102 409-0
Fax: +49 (0)2102 409-406

Vertriebsgebiet Mitte
 Germany Centre

Bosch Rexroth AG
Regionalzentrum Mitte
Waldecker Straße 13
64546 Mörfelden-Walldorf

Tel.: +49 (0) 61 05 702-3
Fax: +49 (0) 61 05 702-444

Vertriebsgebiet Nord
 Germany North

Bosch Rexroth AG
Walsroder Str. 93
30853 Langenhagen

Tel.: +49 (0) 511 72 66 57-0
Service: +49 (0) 511 72 66 57-256
Fax: +49 (0) 511 72 66 57-93
Service: +49 (0) 511 72 66 57-95
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Europa (West) - Europe (West)

vom Ausland: (0) nach Landeskennziffer weglassen, Italien: 0 nach Landeskennziffer mitwählen
from abroad:    don’t dial (0) after country code, Italy:    dial 0 after country code

Austria - Österreich

Bosch Rexroth GmbH
Bereich Indramat
Stachegasse 13
1120 Wien

Tel.: +43 (0)1 985 25 40
Fax: +43 (0)1 985 25 40-93

Austria – Österreich

Bosch Rexroth G.m.b.H.
Gesch.ber. Rexroth Indramat
Industriepark 18
4061 Pasching

Tel.: +43 (0)7221 605-0
Fax: +43 (0)7221 605-21

Belgium - Belgien

Bosch Rexroth AG
Electric Drives & Controls
Industrielaan 8
1740 Ternat
Tel.: +32 (0)2 5830719
- service: +32 (0)2 5830717
Fax: +32 (0)2 5830731
 indramat@boschrexroth.be

Denmark - Dänemark

BEC A/S
Zinkvej 6
8900 Randers

Tel.: +45 (0)87 11 90 60
Fax: +45 (0)87 11 90 61

Great Britain – Großbritannien

Bosch Rexroth Ltd.
Rexroth Indramat Division
Broadway Lane, South Cerney
Cirencester, Glos GL7 5UH

Tel.: +44 (0)1285 863000
Fax: +44 (0)1285 863030
 sales@boschrexroth.co.uk
 service@boschrexroth.co.uk

Finland - Finnland

Bosch Rexroth Oy
Rexroth Indramat division
Ansatie 6
017 40 Vantaa

Tel.: +358 (0)9 84 91-11
Fax: +358 (0)9 84 91-13 60

France - Frankreich

Bosch Rexroth S.A.
Division Rexroth Indramat
Avenue de la Trentaine
BP. 74
77503 Chelles Cedex

Tel.: +33 (0)164 72-70 00
Fax: +33 (0)164 72-63 00
Hotline: +33 (0)608 33 43 28

France - Frankreich

Bosch Rexroth S.A.
Division Rexroth Indramat
1270, Avenue de Lardenne
31100 Toulouse

Tel.: +33 (0)5 61 49 95 19
Fax: +33 (0)5 61 31 00 41

France - Frankreich

Bosch Rexroth S.A.
Division Rexroth Indramat
91, Bd. Irène Joliot-Curie
69634 Vénissieux – Cedex

Tel.: +33 (0)4 78 78 53 65
Fax: +33 (0)4 78 78 53 62

Italy - Italien

Bosch Rexroth S.p.A.
Via G. Di Vittoria, 1
20063 Cernusco S/N.MI

Tel.: +39 02 2 365 270
Fax: +39 02 700 408 252378

Italy - Italien

Bosch Rexroth S.p.A.
Via Paolo Veronesi, 250
10148 Torino

Tel.: +39 011 224 88 11
Fax: +39 011 224 88 30

Italy - Italien

Bosch Rexroth S.p.A.
Via del Progresso, 16 (Zona Ind.)
35020 Padova

Tel.: +39 049 8 70 13 70
Fax: +39 049 8 70 13 77

Italy - Italien

Bosch Rexroth S.p.A.
Via Mascia, 1
80053 Castellamare di Stabia NA

Tel.: +39 081 8 71 57 00
Fax: +39 081 8 71 68 85

Italy - Italien

Bosch Rexroth S.p.A.
Viale Oriani, 38/A
40137 Bologna

Tel.: +39 051 34 14 14
Fax: +39 051 34 14 22

Netherlands – Niederlande/Holland

Bosch Rexroth B.V.
Kruisbroeksestraat 1
(P.O. Box 32)
5281 RV Boxtel

Tel.: +31 (0)411 65 19 51
Fax: +31 (0)411 65 14 83
 indramat@hydraudyne.nl

Netherlands - Niederlande/Holland

Bosch Rexroth Services B.V.
Kruisbroeksestraat 1
(P.O. Box 32)
5281 RV Boxtel

Tel.: +31 (0)411 65 19 51
Fax: +31 (0)411 67 78 14

Norway - Norwegen

Bosch Rexroth AS
Rexroth Indramat Division
Berghagan 1          or: Box 3007
1405 Ski-Langhus     1402 Ski

Tel.: +47 (0)64 86 41 00
Fax: +47 (0)64 86 90 62
 jul.ruud@rexroth.no

Spain - Spanien

Bosch Rexroth S.A.
Divisiòn Rexroth Indramat
Centro Industrial Santiga
Obradors s/n
08130 Santa Perpetua de Mogoda
Barcelona

Tel.: +34 9 37 47 94 00
Fax: +34 9 37 47 94 01

Spain – Spanien

Goimendi S.A.
División Rexroth Indramat
Parque Empresarial Zuatzu
C/ Francisco Grandmontagne no.2
20018 San Sebastian

Tel.: +34 9 43 31 84 21
- service: +34 9 43 31 84 56
Fax: +34 9 43 31 84 27
- service: +34 9 43 31 84 60
 sat.indramat@goimendi.es

Sweden - Schweden

Rexroth Mecman Svenska AB
Rexroth Indramat Division
- Varuvägen 7
(Service: Konsumentvägen 4, Älfsjö)
125 81 Stockholm

Tel.: +46 (0)8 727 92 00
Fax: +46 (0)8 647 32 77

Sweden - Schweden

Rexroth Mecman Svenska AB
Indramat Support
Ekvändan 7
254 67 Helsingborg

Tel.: +46 (0) 42 38 88 -50
Fax: +46 (0) 42 38 88 -74

Switzerland West - Schweiz West

Bosch Rexroth Suisse SA
Département Rexroth Indramat
Rue du village 1
1020 Renens

Tel.: +41 (0)21 632 84 20
Fax: +41 (0)21 632 84 21

Switzerland East - Schweiz Ost

Bosch Rexroth Schweiz AG
Geschäftsbereich Indramat
Hemrietstrasse 2
8863 Buttikon
Tel. +41 (0) 55 46 46 111
Fax +41 (0) 55 46 46 222
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Europa (Ost) - Europe (East)

vom Ausland: (0) nach Landeskennziffer weglassen  
from abroad:    don’t dial (0) after country code

Czech Republic - Tschechien

Bosch -Rexroth, spol.s.r.o.
Hviezdoslavova 5
627 00 Brno

Tel.: +420 (0)5 48 126 358
Fax: +420 (0)5 48 126 112

Czech Republic - Tschechien

DEL a.s.
Strojírenská 38
591 01 Zdar nad Sázavou
Tel.: +420 616 64 3144
Fax: +420 616 62 1657

Hungary - Ungarn

Bosch Rexroth Kft.
Angol utca 34
1149 Budapest

Tel.: +36 (1) 364 00 02
Fax: +36 (1) 383 19 80

Poland – Polen

Bosch Rexroth Sp.zo.o.
ul. Staszica 1
05-800 Pruszków

Tel.: +48 22 738 18 00
– service: +48 22 738 18 46
Fax: +48 22 758 87 35
– service: +48 22 738 18 42

Poland – Polen

Bosch Rexroth Sp.zo.o.
Biuro Poznan
ul. Dabrowskiego 81/85
60-529 Poznan

Tel.: +48 061 847 64 62 /-63
Fax: +48 061 847 64 02

Rumania - Rumänien

Bosch Rexroth Sp.zo.o.
Str. Drobety nr. 4-10, app. 14
70258 Bucuresti, Sector 2

Tel.: +40 (0)1 210 48 25
+40 (0)1 210 29 50

Fax: +40 (0)1 210 29 52

Russia - Russland

Bosch Rexroth OOO
Wjatskaja ul. 27/15
127015 Moskau

Tel.: +7-095-785 74 78
+7-095 785 74 79

Fax: +7 095 785 74 77
 laura.kanina@boschrexroth.ru

Russia - Russland

ELMIS
10, Internationalnaya
246640 Gomel, Belarus

Tel.: +375/ 232 53 42 70
+375/ 232 53 21 69

Fax: +375/ 232 53 37 69
 elmis_ltd@yahoo.com

Turkey - Türkei

Bosch Rexroth Otomasyon
San & Tic. A..S.
Fevzi Cakmak Cad No. 3
34630 Sefaköy Istanbul

Tel.: +90 212 541 60 70
Fax: +90 212 599 34 07

Slowenia - Slowenien

DOMEL
Otoki 21
64 228 Zelezniki

Tel.: +386 5 5117 152
Fax: +386 5 5117 225
 brane.ozebek@domel.si
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Africa, Asia, Australia – incl. Pacific Rim

Australia - Australien

AIMS - Australian Industrial
Machinery Services Pty. Ltd.
Unit 3/45 Horne ST
Campbellfield , VIC 3061
Melbourne
Tel.: +61  393 590 228
Fax: +61  393 590 286
Hotline: +61  419 369 195
 terryobrien@aimservices.com.au

Australia - Australien

Bosch Rexroth Pty. Ltd.
No. 7, Endeavour Way
Braeside Victoria, 31 95
Melbourne

Tel.: +61 3 95 80 39 33
Fax: +61 3 95 80 17 33
 mel@rexroth.com.au

China

Shanghai Bosch Rexroth
Hydraulics & Automation Ltd.
Wai Gao Qiao Free Trade Zone
No.122, Fu Te Dong Yi Road
Shanghai 200131 - P.R.China

Tel.: +86 21 58 66 30 30
Fax: +86 21 58 66 55 23
 roger.shi_sh@boschrexroth.com.cn

China

Bosch Rexroth (China) Ltd.
15/F China World Trade Center
1, Jianguomenwai Avenue
Beijing 100004, P.R.China

Tel.: +86 10 65 05 03 80
Fax: +86 10 65 05 03 79

China

Bosch Rexroth (China) Ltd.
A-5F., 123 Lian Shan Street
Sha He Kou District
Dalian 116 023, P.R.China

Tel.: +86 411 46 78 930
Fax: +86 411 46 78 932

China

Bosch Rexroth (Changzhou) Co.Ltd.
Guangzhou Repres. Office
Room 1014-1016, Metro Plaza,
Tian He District, 183 Tian He Bei Rd
Guangzhou 510075, P.R.China

Tel.: +86 20 8755-0030
+86 20 8755-0011

Fax: +86 20 8755-2387

Hongkong

Bosch Rexroth (China) Ltd.
6th Floor,
Yeung Yiu Chung No.6 Ind Bldg.
19 Cheung Shun Street
Cheung Sha Wan,
Kowloon, Hongkong

Tel.: +852 22 62 51 00
Fax: +852 27 41 33 44

alexis.siu@boschrexroth.com.hk

India - Indien

Bosch Rexroth (India) Ltd.
Rexroth Indramat Division
Plot. A-58, TTC Industrial Area
Thane Turbhe Midc Road
Mahape Village
Navi Mumbai - 400 701

Tel.: +91 22 7 61 46 22
Fax: +91 22 7 68 15 31

India - Indien

Bosch Rexroth (India) Ltd.
Rexroth Indramat Division
Plot. 96, Phase III
Peenya Industrial Area
Bangalore - 560058

Tel.: +91 80 41 70 211
Fax: +91 80 83 94 345

 rexbang@bgl.vsnl.net.in

Indonesia - Indonesien

PT. Rexroth Wijayakusuma
Building # 202, Cilandak
Commercial Estate
Jl. Cilandak KKO, Jakarta 12560

Tel.: +62 21 7891169 (5 lines)
Fax: +62 21 7891170 - 71

Japan

Bosch Rexroth Automation Corp.
Service Center Japan
Yutakagaoka 1810, Meito-ku,
NAGOYA 465-0035, Japan

Tel.: +81 52 777 88 41
+81 52 777 88 53
+81 52 777 88 79

Fax: +81 52 777 89 01

Japan

Bosch Rexroth Automation Corp.
Rexroth Indramat Division
1F, I.R. Building
Nakamachidai 4-26-44, Tsuzuki-ku
YOKOHAMA 224-0041, Japan

Tel.: +81 45 942 72 10
Fax: +81 45 942 03 41

Korea

Bosch Rexroth-Korea Ltd.
1515-14 Dadae-Dong, Saha-Ku
Rexroth Indramat Division
Pusan Metropolitan City, 604-050
Republic of South Korea

Tel.: +82 51 26 00 741
Fax: +82 51 26 00 747
 gyhan@rexrothkorea.co.kr

Malaysia

Bosch Rexroth Sdn.Bhd.
11, Jalan U8/82
Seksyen U8
40150 Shah Alam
Selangor, Malaysia

Tel.: +60  3 78 44 80 00
Fax: +60  3 78 45 48 00
 hockhwa@hotmail.com
 rexroth1@tm.net.my

Singapore - Singapur

Bosch Rexroth SDN BHD.
No.11, Jalan Astaka U8/82
Seksyen U8
40150 Shah Alam
Selangor Darul Ehsan

Tel.: +65  3 7844 8000
Fax: +65  3 7845 4800

 kenton.peh@boschrexroth.com.sg

South Africa - Südafrika

TECTRA Automation (Pty) Ltd.
71 Watt Street, Meadowdale
Edenvale 1609

Tel.: +27 11 971 94 00
Fax: +27 11 971 94 40
Hotline: +27 82 903 29 23
 georgv@tectra.co.za

Taiwan

Rexroth Uchida Co., Ltd.
No.17, Lane 136, Cheng Bei 1 Rd.,
Yungkang, Tainan Hsien
Taiwan, R.O.C.

Tel.: +886 6 25 36 565
Fax: +886 6 25 34 754
 indra.charlie@msa.hinet.net

Thailand

NC Advance Technology Co. Ltd.
59/76 Moo 9
Ramintra road 34
Tharang, Bangkhen,
Bangkok 10230

Tel.: +66 2 943 70 62
        +66 2 943 71 21
Fax: +66 2 509 23 62
 sonkawin@hotmail.com
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Nordamerika – North America
USA
Hauptniederlassung - Headquarters

Bosch Rexroth Corporation
Rexroth Indramat Division
5150 Prairie Stone Parkway
Hoffman Estates, IL 60192-3707

Tel.: +1 847 6 45 36 00
Fax: +1 847 6 45 62 01
servicebrc@boschrexroth-us.com
 repairbrc@boschrexroth-us.com

USA Central Region - Mitte

Bosch Rexroth Corporation
Rexroth Indramat Division
Central Region Technical Center
1701 Harmon Road
Auburn Hills, MI 48326

Tel.: +1 248 3 93 33 30
Fax: +1 248 3 93 29 06

USA Southeast Region - Südwest

Bosch Rexroth Corporation
Rexroth Indramat Division
Southeastern Technical Center
3625 Swiftwater Park Drive
Suwanee, Georgia 30124

Tel.: +1 770 9 32 32 00
Fax: +1 770 9 32 19 03

USA SERVICE-HOTLINE

- 7 days x 24hrs -

+1-800-860-1055

USA East Region –Ost

Bosch Rexroth Corporation
Rexroth Indramat Division
Charlotte Regional  Sales Office
14001 South Lakes Drive
Charlotte, North Carolina 28273

Tel.: +1 704 5 83 97 62
+1 704 5 83 14 86

USA Northeast Region – Nordost

Bosch Rexroth Corporation
Rexroth Indramat Division
Northeastern Technical Center
99 Rainbow Road
East Granby, Connecticut 06026

Tel.: +1 860 8 44 83 77
Fax: +1 860 8 44 85 95

USA West Region – West

Bosch Rexroth Corporation
7901 Stoneridge Drive, Suite 220
Pleasant Hill, California 94588

Tel.: +1 925 227 10 84
Fax: +1 925 227 10 81

Canada East - Kanada Ost

Bosch Rexroth Canada Corporation
Burlington Division
3426 Mainway Drive
Burlington, Ontario
Canada L7M 1A8

Tel.: +1 905 335 55 11
Fax: +1 905 335-41 84
 michael.moro@boschrexroth.ca

Canada West - Kanada West

Bosch Rexroth Canada Corporation
5345 Goring St.
Burnaby, British Columbia
Canada V7J 1R1

Tel. +1 604   205-5777
Fax +1 604   205-6944
 david.gunby@boschrexroth.ca

Mexico

Bosch Rexroth S.A. de C.V.
Calle Neptuno 72
Unidad Ind. Vallejo
07700 Mexico, D.F.

Tel.: +52 5 754 17 11
+52 5 754 36 84
+52 5 754 12 60

Fax: +52 5 754 50 73
+52 5 752 59 43

Mexico

Bosch Rexroth S.A. de C.V.
Calle Argentina No 3913
Fracc. las Torres
64930 Monterey, N.L.

Tel.: +52 8 333 88 34...36
+52 8 349 80 91...93

Fax: +52 8 346 78 71
mario.quiroga@boschrexroth.com.mx

Südamerika –  South America
Argentina - Argentinien

Bosch Rexroth S.A.I.C.
"The Drive & Control Company"
Acassusso 48 41/47
1605 Munro
Provincia de Buenos Aires

Tel.: +54 11 4756 01 40
Fax: +54 11 4756 01 36
victor.jabif@boschrexroth.com.ar

Argentina - Argentinien

NAKASE
Servicio Tecnico CNC
Calle 49, No. 5764/66
B1653AOX Villa Balester
Provincia de Buenos Aires

Tel.: +54  11 4768 36 43
Fax: +54  11 4768 24 13
 nakase@usa.net
 nakase@nakase.com
 gerencia@nakase.com (Service)

Brazil - Brasilien

Bosch Rexroth Ltda.
Av. Tégula, 888
Ponte Alta, Atibaia SP
CEP 12942-440

Tel.: +55 11  4414 56 92
+55 11  4414 56 84

Fax sales: +55 11  4414 57 07
Fax serv.: +55 11  4414 56 86
 alexandre.wittwer@rexroth.com.br

Brazil - Brasilien

Bosch Rexroth  Ltda.
R. Dr.Humberto Pinheiro Vieira, 100
Distrito Industrial    [Caixa Postal 1273]
89220-390 Joinville - SC

Tel./Fax: +55 47 473 58 33
Mobil: +55 47 9974 6645
 prochnow@zaz.com.br

Columbia - Kolumbien

Reflutec de Colombia Ltda.
Calle 37 No. 22-31
Santafé de Bogotá, D.C.
Colombia

Tel.: +57 1 368 82 67
+57 1 368 02 59

Fax: +57 1 268 97 37
reflutec@neutel.com.co
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